summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-29 17:32:48 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:52:26 -0400
commit55fc0947d484f13dec89a4897b9313c8079b1d98 (patch)
treeda628769214d9fa97a81a7d10da312769dbd2464 /gnu
parent0837d0aaf199f4826614f588342b871825273c25 (diff)
downloadguix-patches-55fc0947d484f13dec89a4897b9313c8079b1d98.tar
guix-patches-55fc0947d484f13dec89a4897b9313c8079b1d98.tar.gz
gnu: Remove python2-parameterized.
* gnu/packages/check.scm (python2-parameterized): Delete variable. * gnu/packages/patches/python2-parameterized-docstring-test.patch: Delete file. * gnu/local.mk (dist_patch_DATA): De-register it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/check.scm11
-rw-r--r--gnu/packages/patches/python2-parameterized-docstring-test.patch18
3 files changed, 0 insertions, 30 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 93b4902151..3452b75e3b 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1705,7 +1705,6 @@ dist_patch_DATA = \
%D%/packages/patches/python-mox3-python3.6-compat.patch \
%D%/packages/patches/python-typing-inspect-fix.patch \
%D%/packages/patches/python-packaging-test-arch.patch \
- %D%/packages/patches/python2-parameterized-docstring-test.patch \
%D%/packages/patches/python-paste-remove-timing-test.patch \
%D%/packages/patches/python-pycrypto-CVE-2013-7459.patch \
%D%/packages/patches/python-pycrypto-time-clock.patch \
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 69644aefec..197205a47e 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -818,19 +818,8 @@ but it works for any C/C++ project.")
(description
"Parameterized is a Python library that aims to fix parameterized testing
for every Python test framework. It supports nose, py.test, and unittest.")
- (properties `((python2-variant . ,(delay python2-parameterized))))
(license license:bsd-2)))
-(define-public python2-parameterized
- (let ((base (package-with-python2 (strip-python2-variant
- python-parameterized))))
- (package/inherit
- base
- (source
- (origin
- (inherit (package-source base))
- (patches (search-patches "python2-parameterized-docstring-test.patch")))))))
-
(define-public python-minimock
(package
(name "python-minimock")
diff --git a/gnu/packages/patches/python2-parameterized-docstring-test.patch b/gnu/packages/patches/python2-parameterized-docstring-test.patch
deleted file mode 100644
index 14691e1904..0000000000
--- a/gnu/packages/patches/python2-parameterized-docstring-test.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Skip unicode docstring test, required when running on Python 2.
-
-See <https://github.com/wolever/parameterized/issues/44>.
-
---- a/parameterized/test.py
-+++ b/parameterized/test.py
-@@ -284,11 +284,6 @@
- " More" %(foo, )
- )
-
-- @parameterized.expand([param("foo")])
-- def test_unicode_docstring(self, foo):
-- u"""Döcumentation."""
-- self._assert_docstring(u"Döcumentation [with foo=%r]." %(foo, ))
--
- @parameterized.expand([param("foo", )])
- def test_default_values_get_correct_value(self, foo, bar=12):
- """Documentation"""