summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2019-08-23 18:41:05 +0200
committerLudovic Courtès <ludo@gnu.org>2019-08-23 18:41:49 +0200
commit9dd5f4752844c1445fd1b1dd3927ca8e9e4f8abd (patch)
tree5ad6036f8ea178a793d65ed6ec73d09300daafc0 /gnu
parent90c98b5a89038c41a0db0add9e2a3d4d1a1b6102 (diff)
downloadguix-patches-9dd5f4752844c1445fd1b1dd3927ca8e9e4f8abd.tar
guix-patches-9dd5f4752844c1445fd1b1dd3927ca8e9e4f8abd.tar.gz
gnu: Add JUBE.
* gnu/packages/python-xyz.scm (jube): New variable. Co-authored-by: Florent Pruvost <florent.pruvost@inria.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6f4c3b79d0..135ff05237 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16089,3 +16089,28 @@ The library has a number of built-in tilesets from OpenStreetMap, Mapbox, and
Stamen, and supports custom tilesets with Mapbox or Cloudmade API keys. It
supports Image, Video, GeoJSON and TopoJSON overlays.")
(license license:expat)))
+
+(define-public jube
+ (package
+ ;; This is a command-line tool, so no "python-" prefix.
+ (name "jube")
+ (version "2.2.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://apps.fz-juelich.de/jsc/jube/jube2/download.php?version="
+ version))
+ (sha256
+ (base32
+ "0xq4k1q63s1p6swgyp61vahlrd1fqmgbm0gm5kpj8ikwy0yc0nqk"))
+ (file-name (string-append "jube-" version ".tar.gz"))))
+ (build-system python-build-system)
+ (home-page "https://apps.fz-juelich.de/jsc/jube/jube2/docu/index.html")
+ (synopsis "Benchmarking environment")
+ (description
+ "JUBE helps perform and analyze benchmarks in a systematic way. For each
+benchmarked application, benchmark data is stored in a format that allows JUBE
+to deduct the desired information. This data can be parsed by automatic pre-
+and post-processing scripts that draw information and store it more densely
+for manual interpretation.")
+ (license license:expat)))