summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-11-12 12:09:56 -0500
committerLeo Famulari <leo@famulari.name>2018-11-18 18:19:34 -0500
commit5c40a69f7123f8f6ec4f1792bea73bb345a445b0 (patch)
tree76369b7f77ac1b35b8f700a55dbb01f27ae4fb8a /gnu
parentab6caf4f1d94a5e8f58cbdfde15d7bef77eb25c4 (diff)
downloadguix-patches-5c40a69f7123f8f6ec4f1792bea73bb345a445b0.tar
guix-patches-5c40a69f7123f8f6ec4f1792bea73bb345a445b0.tar.gz
gnu: Add libfdk 'FDK AAC' library.
* gnu/packages/audio.scm (libfdk): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/audio.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 6795ddd21c..d74f50fac5 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -3549,3 +3549,37 @@ using ALSA, MPD, PulseAudio, or a FIFO buffer as its input.")
(synopsis "Pro-quality GM soundfont")
(description "Fluid-3 is Frank Wen's pro-quality GM soundfont.")
(license license:expat))))
+
+(define-public libfdk
+ (let ((commit "2326faaf8f2cdf2c3a9108ccdaf1d7551aec543e")
+ (revision "0"))
+ (package
+ (name "libfdk")
+ ;; The latest upstream revision, with many bug fixes.
+ (version (git-version "0.1.6" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mstorsjo/fdk-aac")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0yy6ndd9d61bwl283vl1r5kva2a4acc0f4r9g0sza156f2abr9ws"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
+ (home-page "https://github.com/mstorsjo/fdk-aac")
+ (synopsis "Fraunhofer FDK AAC library")
+ (description "FDK is a library for encoding and decoding Advanced Audio
+Coding (AAC) format audio, developed by Fraunhofer IIS, and included as part of
+Android. It supports several Audio Object Types including MPEG-2 and MPEG-4 AAC
+LC, HE-AAC (AAC LC + SBR), HE-AACv2 (LC + SBR + PS) as well AAC-LD (low delay)
+and AAC-ELD (enhanced low delay) for real-time communication. The encoding
+library supports sample rates up to 96 kHz and up to eight channels (7.1
+surround).")
+ (license (license:fsf-free "https://github.com/mstorsjo/fdk-aac/blob/master/NOTICE"
+ "https://www.gnu.org/licenses/license-list.html#fdk")))))