summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLaFreniere, Joseph <joseph@lafreniere.xyz>2019-05-30 15:17:53 -0500
committerRicardo Wurmus <rekado@elephly.net>2019-05-31 10:15:52 +0200
commit8ae48674ce3493fddfdc0d2acead285396ed1da0 (patch)
treefc73cb3eb7e6c3399100a4d920bab8953d73924b /gnu
parentb0eaead510da14c66f7d3b81e6eeae6c5a8445db (diff)
downloadguix-patches-8ae48674ce3493fddfdc0d2acead285396ed1da0.tar
guix-patches-8ae48674ce3493fddfdc0d2acead285396ed1da0.tar.gz
gnu: Add emacs-reformatter.
* gnu/packages/emacs-xyz.scm (emacs-reformatter): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6467507d11..1b0e623bbd 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -804,6 +804,29 @@ skip set strings, which are arguments to @code{skip-chars-forward} and
@code{skip-chars-backward}.")
(license license:gpl3+)))
+(define-public emacs-reformatter
+ (package
+ (name "emacs-reformatter")
+ (version "0.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/purcell/reformatter.el.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0hhy6x1bkwlhdlarsgm06g3am4yh02yqv8qs34szpzgy53x84qah"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/purcell/reformatter.el")
+ (synopsis "Define commands which run reformatters on the current buffer")
+ (description
+ "This library lets elisp authors easily define an idiomatic command to
+reformat the current buffer using a command-line program, together with an
+optional minor mode which can apply this command automatically on save.")
+ (license license:gpl3+)))
+
(define-public emacs-relint
(package
(name "emacs-relint")