summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Hashe <david.hashe@dhashe.com>2015-07-15 22:52:22 -0500
committer宋文武 <iyzsong@gmail.com>2015-07-17 20:48:22 +0800
commitf70d8383eee2c6cbc29d2527aac176ecf908d8c4 (patch)
treef2b10f8992306da54c3416c6135e950efa9e3352 /gnu
parent177b42552f0f1aa5c5e52f5e441a00eaac9def8e (diff)
downloadguix-patches-f70d8383eee2c6cbc29d2527aac176ecf908d8c4.tar
guix-patches-f70d8383eee2c6cbc29d2527aac176ecf908d8c4.tar.gz
gnu: Add eog.
* gnu/packages/gnome.scm (eog): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm51
1 files changed, 51 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index da8dd87f1c..0ae7c252ad 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -62,6 +62,7 @@
#:use-module (gnu packages lua)
#:use-module (gnu packages image)
#:use-module (gnu packages perl)
+ #:use-module (gnu packages photo)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages python)
@@ -3024,3 +3025,53 @@ which can read a large number of file formats.")
(description "Rhythmbox is a music playing application for GNOME. It
supports playlists, song ratings, and any codecs installed through gstreamer.")
(license license:gpl2+)))
+
+(define-public eog
+ (package
+ (name "eog")
+ (version "3.16.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0frw1b5jix9pffznav5s7ajjx91a8rv5lf4sjvjv3fw65mbnhbw0"))))
+ (build-system glib-or-gtk-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after
+ 'install 'wrap-eog
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (gi-typelib-path (getenv "GI_TYPELIB_PATH")))
+ (wrap-program (string-append out "/bin/eog")
+ `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))))
+ #t)))))
+ (propagated-inputs
+ `(("dconf" ,dconf)))
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("itstool", itstool)
+ ("glib" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("gnome-desktop" ,gnome-desktop)
+ ("shared-mime-info" ,shared-mime-info)
+ ("adwaita-icon-theme" ,adwaita-icon-theme)
+ ("exempi" ,exempi)
+ ("lcms" ,lcms)
+ ("libexif" ,libexif)
+ ("libpeas" ,libpeas)
+ ("libjpeg" ,libjpeg)
+ ("librsvg" ,librsvg)
+ ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("gtk+" ,gtk+)))
+ (home-page "https://wiki.gnome.org/Apps/EyeOfGnome")
+ (synopsis "GNOME image viewer")
+ (description "Eye of GNOME is the GNOME image viewer. It
+supports image conversion, rotation, and slideshows.")
+ (license license:gpl2+)))