summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-12-13 19:20:47 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2017-12-14 00:05:15 +0100
commitda43edbe0f54ea1cf0c71bd8e30572d0e8ac336a (patch)
tree7df40dbfab8bc33d4fe80103fdb0a7130bb47f7c /gnu
parente2e6e9ebf00d1e37a614a5915019a836def07d99 (diff)
downloadguix-patches-da43edbe0f54ea1cf0c71bd8e30572d0e8ac336a.tar
guix-patches-da43edbe0f54ea1cf0c71bd8e30572d0e8ac336a.tar.gz
gnu: Add perl-time-piece.
* gnu/packages/perl.scm (perl-time-piece): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 73bab96a26..7ff55546c6 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -7890,6 +7890,28 @@ six-element array, and return the corresponding time(2) value in seconds since
the system epoch.")
(license (package-license perl))))
+(define-public perl-time-piece
+ (package
+ (name "perl-time-piece")
+ (version "1.3203")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/E/ES/ESAYM/Time-Piece-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0hbg99v8xqy3nx6nrjpwh1w6xwqpfflz0djkbdd72kvf8zvglwb9"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/Time-Piece/")
+ (synopsis "Object-Oriented time objects")
+ (description
+ "This module replaces the standard @code{localtime} and @code{gmtime}
+functions with implementations that return objects. It does so in a
+backwards-compatible manner, so that using these functions as documented will
+still work as expected.")
+ (license perl-license)))
+
(define-public perl-timedate
(package
(name "perl-timedate")