summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2017-12-11 19:34:01 +0530
committerArun Isaac <arunisaac@systemreboot.net>2017-12-13 23:49:14 +0530
commitd738f134e496f3a954e51d3625d3eb1fcd5e638d (patch)
tree6ed3de8006f5e9343b90cea31b1e2e158981d02a /gnu
parentcc6a4b03867bc18baf30c0239c3c6dbf0709de7a (diff)
downloadguix-patches-d738f134e496f3a954e51d3625d3eb1fcd5e638d.tar
guix-patches-d738f134e496f3a954e51d3625d3eb1fcd5e638d.tar.gz
gnu: notmuch: Move elisp directory and generate autoloads.
* gnu/packages/mail.scm (notmuch)[arguments]: Move elisp files to share/emacs/site-lisp/guix.d/notmuch-<version>. Add make-autoloads phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/mail.scm25
1 files changed, 20 insertions, 5 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 89062da3b7..590bdd5135 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -703,7 +703,13 @@ invoking @command{notifymuch} from the post-new hook.")
"1fyx20rjpwbf2j1v5fpa5s0rjnwhcgvijzh2qyinp8rlbh1qxmab"))))
(build-system gnu-build-system)
(arguments
- '(#:make-flags (list "V=1") ; Verbose test output.
+ `(#:modules ((guix build gnu-build-system)
+ ((guix build emacs-build-system) #:prefix emacs:)
+ (guix build utils))
+ #:imported-modules (,@%gnu-build-system-modules
+ (guix build emacs-build-system)
+ (guix build emacs-utils))
+ #:make-flags (list "V=1") ; Verbose test output.
#:phases (modify-phases %standard-phases
(add-after 'unpack 'patch-notmuch-lib.el
(lambda _
@@ -715,16 +721,25 @@ invoking @command{notifymuch} from the post-new hook.")
(setenv "CC" "gcc")
(setenv "CONFIG_SHELL" (which "sh"))
- (let ((out (assoc-ref outputs "out")))
- (zero? (system* "./configure"
- (string-append "--prefix=" out))))))
+ (let* ((out (assoc-ref outputs "out"))
+ (elisp
+ (string-append out "/share/emacs/site-lisp/guix.d/"
+ ,name "-" ,version)))
+ (zero?
+ (system*
+ "./configure"
+ (string-append "--prefix=" out)
+ (string-append "--emacslispdir=" elisp)
+ (string-append "--emacsetcdir=" elisp))))))
(add-before 'check 'prepare-test-environment
(lambda _
(setenv "TEST_CC" "gcc")
;; Patch various inline shell invocations.
(substitute* (find-files "test" "\\.sh$")
(("/bin/sh") (which "sh")))
- #t)))))
+ #t))
+ (add-after 'install 'make-autoloads
+ (assoc-ref emacs:%standard-phases 'make-autoloads)))))
(native-inputs
`(("bash-completion" ,bash-completion)
("emacs" ,emacs-no-x) ; Minimal lacks libxml, needed for some tests.