summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-10-31 13:08:27 -0400
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:25 -0500
commitb6b2c2183bdd8271f8926650b9751dbee20a3ddd (patch)
tree8eb6baba7503538a114734383ca548c6ddaf415c /gnu
parente2303abb5c061debc4d6224ac7ce57640fcc7f13 (diff)
downloadguix-patches-b6b2c2183bdd8271f8926650b9751dbee20a3ddd.tar
guix-patches-b6b2c2183bdd8271f8926650b9751dbee20a3ddd.tar.gz
gnu: ghc-cgi: Update to 3001.4.0.0.
* gnu/packages/haskell-xyz.scm (ghc-cgi): Update to 3001.4.0.0. [arguments]: Remove the 'update-constraints' phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell-xyz.scm18
1 files changed, 2 insertions, 16 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 27daca10c0..4da0455a09 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -1398,7 +1398,7 @@ parser isolation, and labeled blocks for better error messages.")
(define-public ghc-cgi
(package
(name "ghc-cgi")
- (version "3001.3.0.2")
+ (version "3001.4.0.0")
(source
(origin
(method url-fetch)
@@ -1408,22 +1408,8 @@ parser isolation, and labeled blocks for better error messages.")
".tar.gz"))
(sha256
(base32
- "1hbpplss1m4rdpm4ibip6fpimlhssqa14fl338kl2jbc463i64cj"))))
+ "1d0nh5ymkqskkp4yn0gfz4mff8i0cxyw1wws8xxp6k1mg1ywa25k"))))
(build-system haskell-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'configure 'update-constraints
- (lambda _
- (substitute* "cgi.cabal"
- (("exceptions < 0\\.9")
- "exceptions < 0.11")
- (("time >= 1\\.5 && < 1\\.7")
- "time >= 1.5 && < 1.9")
- (("doctest >= 0\\.8 && < 0\\.12")
- "doctest >= 0.8 && < 0.17")
- (("QuickCheck >= 2\\.8\\.1 && < 2\\.10")
- "QuickCheck >= 2.8.1 && < 2.12")))))))
(inputs
`(("ghc-exceptions" ,ghc-exceptions)
("ghc-multipart" ,ghc-multipart)