summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-04-09 14:19:23 +0200
committerMarius Bakke <marius@gnu.org>2022-04-09 14:27:43 +0200
commitaa5716703fd4603dd89ce9b55f555b7aa85f4c9b (patch)
treec5c8d735fe5db5b1ec370e0ee41d417b85737e16 /gnu
parentdce0249f18cfdc899468cc8a1a29235e34d53030 (diff)
downloadguix-patches-aa5716703fd4603dd89ce9b55f555b7aa85f4c9b.tar
guix-patches-aa5716703fd4603dd89ce9b55f555b7aa85f4c9b.tar.gz
gnu: ganeti: Update to 3.0.2.
* gnu/packages/patches/ganeti-haskell-compat.patch, gnu/packages/patches/ganeti-sphinx-compat.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/virtualization.scm (ganeti): Update to 3.0.2. [source](patches): Remove obsolete. [arguments]: Remove obsolete phases. Disable one more test.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk2
-rw-r--r--gnu/packages/patches/ganeti-haskell-compat.patch18
-rw-r--r--gnu/packages/patches/ganeti-sphinx-compat.patch24
-rw-r--r--gnu/packages/virtualization.scm21
4 files changed, 3 insertions, 62 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 2a68d45717..6f426d8dba 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1082,12 +1082,10 @@ dist_patch_DATA = \
%D%/packages/patches/fxdiv-system-libraries.patch \
%D%/packages/patches/gajim-honour-GAJIM_PLUGIN_PATH.patch \
%D%/packages/patches/ganeti-disable-version-symlinks.patch \
- %D%/packages/patches/ganeti-haskell-compat.patch \
%D%/packages/patches/ganeti-haskell-pythondir.patch \
%D%/packages/patches/ganeti-pyyaml-compat.patch \
%D%/packages/patches/ganeti-shepherd-master-failover.patch \
%D%/packages/patches/ganeti-shepherd-support.patch \
- %D%/packages/patches/ganeti-sphinx-compat.patch \
%D%/packages/patches/gash-utils-ls-test.patch \
%D%/packages/patches/gawk-shell.patch \
%D%/packages/patches/gcc-arm-bug-71399.patch \
diff --git a/gnu/packages/patches/ganeti-haskell-compat.patch b/gnu/packages/patches/ganeti-haskell-compat.patch
deleted file mode 100644
index 931c50e116..0000000000
--- a/gnu/packages/patches/ganeti-haskell-compat.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Adjust to type change of TupE in Template Haskell 2.16.
-
-diff --git a/src/Ganeti/THH/Types.hs b/src/Ganeti/THH/Types.hs
---- a/src/Ganeti/THH/Types.hs
-+++ b/src/Ganeti/THH/Types.hs
-@@ -123,4 +123,11 @@ curryN n = do
- f <- newName "f"
- ps <- replicateM n (newName "x")
- return $ LamE (VarP f : map VarP ps)
-- (AppE (VarE f) (TupE $ map VarE ps))
-+ (AppE (VarE f) (nonUnaryTupE $ map VarE ps))
-+ where
-+ nonUnaryTupE :: [Exp] -> Exp
-+ nonUnaryTupE es = TupE $
-+#if MIN_VERSION_template_haskell(2,16,0)
-+ map Just
-+#endif
-+ es
diff --git a/gnu/packages/patches/ganeti-sphinx-compat.patch b/gnu/packages/patches/ganeti-sphinx-compat.patch
deleted file mode 100644
index 4e84abbf37..0000000000
--- a/gnu/packages/patches/ganeti-sphinx-compat.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-Adjust documentation for Sphinx 4.0.
-
-Discussed upstream at <https://github.com/ganeti/ganeti/pull/1615>.
-
-diff --git a/doc/index.rst b/doc/index.rst
---- a/doc/index.rst
-+++ b/doc/index.rst
-@@ -119,7 +119,6 @@ Draft designs
- design-hotplug.rst
- design-internal-shutdown.rst
- design-kvmd.rst
-- design-location.rst
- design-linuxha.rst
- design-location.rst
- design-lu-generated-jobs.rst
-diff --git a/lib/build/shell_example_lexer.py b/lib/build/shell_example_lexer.py
---- a/lib/build/shell_example_lexer.py
-+++ b/lib/build/shell_example_lexer.py
-@@ -79,4 +79,4 @@ class ShellExampleLexer(RegexLexer):
-
-
- def setup(app):
-- app.add_lexer("shell-example", ShellExampleLexer())
-+ app.add_lexer("shell-example", ShellExampleLexer)
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index 1f71f079c2..f3396e7c94 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -547,19 +547,17 @@ firmware blobs. You can
(define-public ganeti
(package
(name "ganeti")
- (version "3.0.1")
+ (version "3.0.2")
(source (origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/ganeti/ganeti")
(commit (string-append "v" version))))
(sha256
- (base32 "1i7gx0sdx9316fnldbv738s0ihym1370nhc1chk0biandkl8vvq0"))
+ (base32 "1xw7rm0k411aj0a4hrxz9drn7827bihp6bwizbapfx8k4c3125k4"))
(file-name (git-file-name name version))
(patches (search-patches "ganeti-shepherd-support.patch"
"ganeti-shepherd-master-failover.patch"
- "ganeti-sphinx-compat.patch"
- "ganeti-haskell-compat.patch"
"ganeti-haskell-pythondir.patch"
"ganeti-pyyaml-compat.patch"
"ganeti-disable-version-symlinks.patch"))))
@@ -612,20 +610,6 @@ firmware blobs. You can
,(system->qemu-target (%current-system))))
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'patch-version-constraints
- (lambda _
- ;; Loosen version constraints for compatibility with Stackage 18.10.
- (substitute* "cabal/ganeti.template.cabal"
- (("(.*base64-bytestring.*) < 1\\.1" _ match)
- (string-append match " < 1.2"))
- (("(.*QuickCheck.*) < 2\\.14" _ match)
- (string-append match " < 2.15")))))
- (add-after 'unpack 'pyparsing-compat
- (lambda _
- ;; Adjust for Pyparsing 3.0. Remove for Ganeti 3.0.2+.
- (substitute* "lib/qlang.py"
- (("operatorPrecedence")
- "infixNotation"))))
(add-after 'unpack 'create-vcs-version
(lambda _
;; If we are building from a git checkout, we need to create a
@@ -717,6 +701,7 @@ firmware blobs. You can
(("test/py/ganeti\\.asyncnotifier_unittest\\.py") "")
(("test/py/ganeti\\.backend_unittest\\.py") "")
(("test/py/ganeti\\.daemon_unittest\\.py") "")
+ (("test/py/ganeti\\.hypervisor\\.hv_kvm_unittest\\.py") "")
(("test/py/ganeti\\.tools\\.ensure_dirs_unittest\\.py") "")
(("test/py/ganeti\\.utils\\.io_unittest-runasroot\\.py") "")
;; Disable the bash_completion test, as it requires the full