summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-01-03 12:08:43 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-01-03 12:49:34 +0200
commit5fea1f5cabfbac0b79702ed01f51eafb40152696 (patch)
treec583f8e9ba5ce01af74d516274f02dd8a1659960 /gnu
parent74287130acaefba2af9a400901d5e8101354f861 (diff)
downloadguix-patches-5fea1f5cabfbac0b79702ed01f51eafb40152696.tar
guix-patches-5fea1f5cabfbac0b79702ed01f51eafb40152696.tar.gz
gnu: Add rust-utf8parse-0.2.
* gnu/packages/crates-io.scm (rust-utf8parse-0.2): New variable. (rust-utf8parse-0.1): Inherit from rust-utf8parse-0.2.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm21
1 files changed, 18 insertions, 3 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 133d649037..a12d611537 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -34921,10 +34921,10 @@ Unix users and groups.")
first byte.")
(license license:expat)))
-(define-public rust-utf8parse-0.1
+(define-public rust-utf8parse-0.2
(package
(name "rust-utf8parse")
- (version "0.1.1")
+ (version "0.2.0")
(source
(origin
(method url-fetch)
@@ -34933,13 +34933,28 @@ first byte.")
(string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0zamsj2986shm4x9zncjf2m5qy9scaw7qnxw4f89b2afpg6a8wl7"))))
+ "0wjkvy22cxg023vkmvq2wwkgqyqam0d4pjld3m13blfg594lnvlk"))))
(build-system cargo-build-system)
(home-page "https://github.com/jwilm/vte")
(synopsis "Table-driven UTF-8 parser")
(description "This package provides a table-driven UTF-8 parser.")
(license (list license:asl2.0 license:expat))))
+(define-public rust-utf8parse-0.1
+ (package
+ (inherit rust-utf8parse-0.2)
+ (name "rust-utf8parse")
+ (version "0.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "utf8parse" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0zamsj2986shm4x9zncjf2m5qy9scaw7qnxw4f89b2afpg6a8wl7"))))))
+
(define-public rust-uuid-0.8
(package
(name "rust-uuid")