summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBrian Leung <leungbk@mailfence.com>2019-10-11 01:27:13 +0200
committerBrian Leung <leungbk@mailfence.com>2019-10-11 05:13:41 +0200
commit3fcdd99f71475e868b95cc8a5a52ece19a1641e9 (patch)
tree5338e728c593f3e8552ca69753ef96ab93174c89 /gnu
parent666f51f9e1bcd7354f4a85a2a8b1b4c6a6cb0d12 (diff)
downloadguix-patches-3fcdd99f71475e868b95cc8a5a52ece19a1641e9.tar
guix-patches-3fcdd99f71475e868b95cc8a5a52ece19a1641e9.tar.gz
gnu: emacs-rspec: Update to 1.11-1.66ea7cc.
* gnu/packages/emacs-xyz.scm (emacs-rspec): Update to 1.11-1.66ea7cc.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm42
1 files changed, 24 insertions, 18 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 69ba1dbd0e..67b178f974 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2946,29 +2946,35 @@ completing keywords and smart indentation.")
(license license:gpl3+))))
(define-public emacs-rspec
- (package
- (name "emacs-rspec")
- (version "1.11")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/pezra/rspec-mode.git")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0hrn5n7aaymwimk511kjij44vqaxbmhly1gwmlmsrnbvvma7f2mp"))))
- (build-system emacs-build-system)
- (home-page "https://github.com/pezra/rspec-mode")
- (synopsis "Provides a rspec mode for working with RSpec")
- (description
- "The Emacs RSpec mode provides keybindings for Ruby source files, e.g. to
+ (let ((commit "66ea7cc9699d6edc6115daa024818adbd85efc20")
+ (revision "1"))
+ (package
+ (name "emacs-rspec")
+ (version (git-version "1.11" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pezra/rspec-mode.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0b11s8r0pi7ah54km4yg4fqff8wkk409d25qnlwm1l94pdwjd1c8"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:include (cons "^snippets\\/rspec-mode\\/" %default-include)
+ #:tests? #t
+ #:test-command '("make" "test")))
+ (home-page "https://github.com/pezra/rspec-mode")
+ (synopsis "Provides a rspec mode for working with RSpec")
+ (description
+ "The Emacs RSpec mode provides keybindings for Ruby source files, e.g. to
verify the spec associated with the current buffer, or entire project, as well
as moving between the spec files, and corresponding code files.
Also included are keybindings for spec files and Dired buffers, as well as
snippets for yasnippet.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-smart-mode-line
(package