summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-08-04 12:48:46 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-08-12 11:57:22 +0300
commit060958949a894f3205523fe9e1f5b5e6bde105de (patch)
tree4259fb4fcf11737d1340487b760bb9e150e34c4a /gnu
parent96c71bffaa0a01a86d59cceec984198d479357dd (diff)
downloadguix-patches-060958949a894f3205523fe9e1f5b5e6bde105de.tar
guix-patches-060958949a894f3205523fe9e1f5b5e6bde105de.tar.gz
gnu: Add rust-autocfg.
* gnu/packages/crates-io.scm (rust-autocfg): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 064ce06692..d4160b6a7f 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019 Ivan Petkov <ivanppetkov@gmail.com>
+;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -26,6 +27,28 @@
;;; Please: Try to add new module packages in alphabetic order.
;;;
+(define-public rust-autocfg
+ (package
+ (name "rust-autocfg")
+ (version "0.1.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "autocfg" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0asl6fnc35yk5l2rxwhp25v128jgm45dp754h9z8x51b6n90w4r2"))))
+ (build-system cargo-build-system)
+ (home-page "https://github.com/cuviper/autocfg")
+ (synopsis "Automatic cfg for Rust compiler features")
+ (description "Rust library for build scripts to automatically configure
+code based on compiler support. Code snippets are dynamically tested to see
+if the @code{rustc} will accept them, rather than hard-coding specific version
+support.")
+ (license (list license:asl2.0
+ license:expat))))
+
(define-public rust-proc-macro2
(package
(name "rust-proc-macro2")