summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-04-29 15:04:09 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-05-15 16:33:45 +0200
commit12f8f9bb3e10d049d242bb005787c1d417f0404a (patch)
tree5bdaf3ca93cd94f01dbd51d576e838de9a020c1b /gnu
parentf6154eb59b3761f018887d1d53c8fee15927dd17 (diff)
downloadguix-patches-12f8f9bb3e10d049d242bb005787c1d417f0404a.tar
guix-patches-12f8f9bb3e10d049d242bb005787c1d417f0404a.tar.gz
gnu: Add python-scikit-image.
* gnu/packages/python.scm (python-scikit-image, python2-scikit-image): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 848a53d1d9..3b9298e6e2 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2065,6 +2065,45 @@ mining and data analysis.")
(alist-delete
"python-scipy" (package-propagated-inputs scikit))))))))
+(define-public python-scikit-image
+ (package
+ (name "python-scikit-image")
+ (version "0.11.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/s/scikit-image/scikit-image-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0jz416fqvpahqyffw8plmszzfj669w8wvf3y9clnr5lr6a7md3kn"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-matplotlib" ,python-matplotlib)
+ ("python-networkx" ,python-networkx)
+ ("python-numpy" ,python-numpy)
+ ("python-scipy" ,python-scipy)
+ ("python-six" ,python-six)
+ ("python-pillow" ,python-pillow)))
+ (native-inputs
+ `(("python-cython" ,python-cython)
+ ("python-setuptools" ,python-setuptools)))
+ (home-page "http://scikit-image.org/")
+ (synopsis "Image processing in Python")
+ (description
+ "scikit-image is a collection of algorithms for image processing.")
+ (license bsd-3)))
+
+(define-public python2-scikit-image
+ (let ((scikit-image (package-with-python2 python-scikit-image)))
+ (package (inherit scikit-image)
+ (native-inputs
+ `(("python2-mock" ,python2-mock)
+ ,@(package-native-inputs scikit-image)))
+ (propagated-inputs
+ `(("python2-pytz" ,python2-pytz)
+ ,@(package-propagated-inputs scikit-image))))))
+
(define-public python-cython
(package
(name "python-cython")