summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-02-20 04:05:09 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-02-20 16:06:08 +0100
commit0dc618067ba54a7090126381fdcf5befb097a863 (patch)
treeb645b0496ef100656d82dfb196207cf91d79fd4f /gnu
parentcb4a178b200a0efa2b27f71cd1421cb7f92911f3 (diff)
downloadguix-patches-0dc618067ba54a7090126381fdcf5befb097a863.tar
guix-patches-0dc618067ba54a7090126381fdcf5befb097a863.tar.gz
gnu: util-macros: Update phase style.
* gnu/packages/xorg.scm (util-macros)[arguments]: Use MODIFY-PHASES syntax and end phases with #t.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xorg.scm31
1 files changed, 16 insertions, 15 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index f5af15e1b8..025d810d7b 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -1863,21 +1863,22 @@ management to participate in an X11R6 session.")
(build-system gnu-build-system)
(native-inputs `(("pkg-config" ,pkg-config)))
(arguments
- `(#:phases (alist-cons-after
- 'unpack 'fix-makefile-in
- (lambda _
- (substitute* "Makefile.in"
- ;; Install xorg-macros.pc in PREFIX/lib/pkgconfig,
- ;; not PREFIX/share/pkgconfig.
- (("\\$\\(datadir\\)/pkgconfig") "$(libdir)/pkgconfig")))
- (alist-cons-after
- 'install 'post-install-cleanup
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (with-directory-excursion out
- (delete-file "share/util-macros/INSTALL")
- (rmdir "share/util-macros"))))
- %standard-phases))))
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-makefile-in
+ (lambda _
+ (substitute* "Makefile.in"
+ ;; Install xorg-macros.pc in PREFIX/lib/pkgconfig,
+ ;; not PREFIX/share/pkgconfig.
+ (("\\$\\(datadir\\)/pkgconfig") "$(libdir)/pkgconfig"))
+ #t))
+ (add-after 'install 'post-install-cleanup
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (with-directory-excursion out
+ (delete-file "share/util-macros/INSTALL")
+ (rmdir "share/util-macros"))
+ #t))))))
(home-page "https://www.x.org/wiki/")
(synopsis "Xorg autoconf macros")
(description