summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-03-06 20:32:56 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-03-10 18:50:00 +0100
commit8acd1e90c5032d8bbcb0cdebc7f659ebdf442802 (patch)
tree1e14304d0a02fbf4c1cdd1df14b0d53b6d17e768 /gnu
parent3d3694079d24756c6963d3e81d5341d6e536a450 (diff)
downloadguix-patches-8acd1e90c5032d8bbcb0cdebc7f659ebdf442802.tar
guix-patches-8acd1e90c5032d8bbcb0cdebc7f659ebdf442802.tar.gz
gnu: python-babel: Disable tests that are incompatible with Pytest 4.
* gnu/packages/python-xyz.scm (python-babel)[arguments]: Expand pytest invokation.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f5bc442a35..bf2fc56294 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -302,7 +302,14 @@ by @code{binstar}, @code{binstar-build} and @code{chalmers}.")
(arguments
`(#:phases (modify-phases %standard-phases
(replace 'check
- (lambda _ (invoke "pytest" "-vv"))))))
+ (lambda _
+ (invoke "pytest" "-vv" "-k"
+ (string-append
+ ;; XXX: These tests fail when using Pytest 4.x and
+ ;; Babel 2.6.0. Try removing this for later versions.
+ "not test_no_inherit_metazone_marker_never_in_output"
+ " and not test_smoke_dates"
+ " and not test_smoke_numbers")))))))
(home-page "http://babel.pocoo.org/")
(synopsis
"Tools for internationalizing Python applications")