summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-04-12 23:08:06 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-04-12 23:12:22 +0200
commit8a6c012deb641705a2b0460f9a64d99bc1f08c73 (patch)
tree8f436e508a97acd232927071a0f6697d7e8d8a28 /gnu
parent9320410d76b213853cb18adc3e2b1e7f0262fbb1 (diff)
downloadguix-patches-8a6c012deb641705a2b0460f9a64d99bc1f08c73.tar
guix-patches-8a6c012deb641705a2b0460f9a64d99bc1f08c73.tar.gz
gnu: python-boto3: Update to 1.21.35.
* gnu/packages/python-xyz.scm (python-boto3): Update to 1.21.35. [arguments]: Override 'check phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4c01d39036..394c7680fd 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14671,7 +14671,7 @@ interface to the Amazon Web Services (AWS) API.")
(define-public python-boto3
(package
(name "python-boto3")
- (version "1.19.11")
+ (version "1.21.35")
(home-page "https://github.com/boto/boto3")
(source (origin
(method git-fetch)
@@ -14679,14 +14679,18 @@ interface to the Amazon Web Services (AWS) API.")
(file-name (git-file-name name version))
(sha256
(base32
- "1wv0ci2z5ywvm63dh4mp64vqyyvkm4qxc8dxv8ncrqiiphpgr9aq"))))
+ "1kdyf238rpfldnpzs0rdh3nhjn6hwfym4faskyhzlgzkf1smmbg1"))))
(arguments
`(#:phases
(modify-phases %standard-phases
(add-after 'unpack 'delete-network-tests
;; Deleting integration tests because they are trying to connect to AWS.
(lambda _
- (delete-file-recursively "tests/integration"))))))
+ (delete-file-recursively "tests/integration")))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-v")))))))
(build-system python-build-system)
(native-inputs
(list python-nose python-mock python-pytest))