summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-10-06 10:28:29 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-10-06 11:02:47 +0200
commit36c737a9c3d906e85c97c919cd6ddb4f95eca2c9 (patch)
tree6809e41334185afed5213faa727d6f6ea1346217 /gnu
parent2fb12dd1bb725592e1561ac8f4b32fb68accb161 (diff)
downloadguix-patches-36c737a9c3d906e85c97c919cd6ddb4f95eca2c9.tar
guix-patches-36c737a9c3d906e85c97c919cd6ddb4f95eca2c9.tar.gz
gnu: libbpf: Fix erroneous use of DESTDIR.
It broke the pkg-config file and is almost always a mistake. * gnu/packages/linux.scm (libbpf)[arguments]: Correctly set PREFIX.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index d0f6a96b3e..574cffaf9d 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7373,9 +7373,8 @@ persistent over reboots.")
`(#:tests? #f ; no tests
#:make-flags
(list
- (string-append "PREFIX=''")
- (string-append "DESTDIR=" (assoc-ref %outputs "out"))
- (string-append "LIBDIR=/lib")
+ (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ (string-append "LIBDIR=$(PREFIX)/lib")
(string-append
"CC=" (assoc-ref %build-inputs "gcc") "/bin/gcc"))
#:phases