summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-02-15 19:17:57 +0100
committerAndreas Enge <andreas@enge.fr>2015-02-15 19:18:29 +0100
commit9e91418b105ad92b259be7588a6f927bb915da9e (patch)
tree912d2cbd9fcde4e2e3e82b0434b02402e4ee2ec9 /gnu
parent605217beaa6399c62e6b333db75afae722db099a (diff)
downloadguix-patches-9e91418b105ad92b259be7588a6f927bb915da9e.tar
guix-patches-9e91418b105ad92b259be7588a6f927bb915da9e.tar.gz
gnu: freetype: Update to 2.5.5.
* gnu/packages/fontutils.scm (freetype): Update to 2.5.5.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/fontutils.scm25
1 files changed, 10 insertions, 15 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 4d4a288d3e..14f42a9236 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -40,28 +40,23 @@
(define-public freetype
(package
(name "freetype")
- (version "2.4.11")
+ (version "2.5.5")
(source (origin
(method url-fetch)
(uri (string-append "mirror://savannah/freetype/freetype-"
- version ".tar.gz"))
+ version ".tar.bz2"))
(sha256 (base32
- "0gpcz6swir64kp0dk3rwgqqkmf48b90dqgczdmznjjryhrahx9r9"))))
+ "1fdgl7js99xv1yy5zx1ravmqd0jxlnqpv7zcl954h4hbg15wqyrq"))))
(build-system gnu-build-system)
(arguments
`(#:phases
- (alist-replace
- 'install
- (lambda* (#:key outputs #:allow-other-keys #:rest args)
- (let ((install (assoc-ref %standard-phases 'install))
- (include (string-append (assoc-ref outputs "out") "/include")))
- (apply install args)
- ;; Unravel one directory, since ft2build.h includes directly from
- ;; freetype/, not freetype2/freetype; this is announced in the file
- ;; to be changed in a future release.
- (symlink (string-append include "/freetype2/freetype")
- (string-append include "/freetype"))))
- %standard-phases)))
+ ;; This should not be necessary; reported upstream as
+ ;; https://savannah.nongnu.org/bugs/index.php?44261
+ (alist-cons-before
+ 'configure 'set-paths
+ (lambda _
+ (setenv "CONFIG_SHELL" (which "bash")))
+ %standard-phases)))
(synopsis "Font rendering library")
(description
"Freetype is a library that can be used by applications to access the