summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorpukkamustard <pukkamustard@posteo.net>2021-06-01 20:22:45 +0000
committerJulien Lepiller <julien@lepiller.eu>2021-06-06 17:16:20 +0200
commit0f62ea0774fee735a97b63a1d2dc9397cc21908b (patch)
treec286a52a53e6143b40ca97aa70b15a5c211f0f12 /gnu
parentb477a9f42e52cf07e05add0632bc01e9d268dd55 (diff)
downloadguix-patches-0f62ea0774fee735a97b63a1d2dc9397cc21908b.tar
guix-patches-0f62ea0774fee735a97b63a1d2dc9397cc21908b.tar.gz
gnu: ocaml-ctypes: Update to 0.18.0.
* gnu/packages/ocaml.scm (ocaml-ctypes): Update to 0.18.0. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index b297a5202e..cf31c2eae7 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3832,7 +3832,7 @@ long and size_t whose sizes depend on the host platform.")
(define-public ocaml-ctypes
(package
(name "ocaml-ctypes")
- (version "0.14.0")
+ (version "0.18.0")
(home-page "https://github.com/ocamllabs/ocaml-ctypes")
(source (origin
(method git-fetch)
@@ -3842,7 +3842,7 @@ long and size_t whose sizes depend on the host platform.")
(file-name (git-file-name name version))
(sha256
(base32
- "1b2q3h63ngf4x9qp65qwapf2dg9q0mcdah6qjm2q0c7v2p5vysv9"))))
+ "03zrbnl16m67ls0yfhq7a4k4238x6x6b3m456g4dw2yqwc153vks"))))
(build-system ocaml-build-system)
(arguments
`(#:tests? #f; require an old lwt
@@ -3861,6 +3861,8 @@ long and size_t whose sizes depend on the host platform.")
(delete 'configure))))
(native-inputs
`(("pkg-config" ,pkg-config)))
+ (propagated-inputs
+ `(("bigarray-compat" ,ocaml-bigarray-compat)))
(inputs
`(("libffi" ,libffi)
("ounit" ,ocaml-ounit)