summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-02-06 19:49:01 +0100
committerJulien Lepiller <julien@lepiller.eu>2017-02-13 22:29:52 +0100
commit5220022a80dccf559127caad7f8ee4592b862411 (patch)
tree3c1ca05ad7624f497b73c3f7cf1682b49b450c34 /gnu
parent51a0887dcff42c62cf7b599edbf1e62814fef51b (diff)
downloadguix-patches-5220022a80dccf559127caad7f8ee4592b862411.tar
guix-patches-5220022a80dccf559127caad7f8ee4592b862411.tar.gz
gnu: Add python-openid.
* gnu/packages/python.scm (python-openid): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm20
1 files changed, 19 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index a049454c48..22a4c590b0 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -31,7 +31,7 @@
;;; Copyright © 2016 Dylan Jeffers <sapientech@sapientech@openmailbox.org>
;;; Copyright © 2016 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2016 Arun Isaac <arunisaac@systemreboot.net>
-;;; Copyright © 2016 Julien Lepiller <julien@lepiller.eu>
+;;; Copyright © 2016, 2017 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2016, 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016 Thomas Danckaert <post@thomasdanckaert.be>
;;; Copyright © 2017 Carlo Zancanaro <carlo@zancanaro.id.au>
@@ -5159,6 +5159,24 @@ features useful for text console applications.")
(define-public python2-urwid
(package-with-python2 python-urwid))
+(define-public python-openid
+ (package
+ (name "python-openid")
+ (version "3.0.10")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "python3-openid" version))
+ (sha256
+ (base32
+ "1x3nh3fycqfn43jp5j5pb4q4y2jxp4mdka4absaa3bc0078qd758"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/necaris/python3-openid")
+ (synopsis "OpenID support for servers and consumers")
+ (description "This library provides OpenID authentication for Python, both
+for clients and servers.")
+ (license license:asl2.0)))
+
(define-public python2-openid
(package
(name "python2-openid")