summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2017-02-11 21:26:36 -0600
committerEric Bavier <bavier@member.fsf.org>2017-02-13 22:28:31 -0600
commit15cd054296a706ed9713c4d09ad06f320cb9efac (patch)
treebe1d794737b8288685bc862202e35e8f182da8fd /gnu
parent0527b43db4843d37106351ac35515a70eb39d727 (diff)
downloadguix-patches-15cd054296a706ed9713c4d09ad06f320cb9efac.tar
guix-patches-15cd054296a706ed9713c4d09ad06f320cb9efac.tar.gz
gnu: Add perl-switch.
* gnu/packages/perl.scm (perl-switch): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index fb294eb42d..eee688354a 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -5746,6 +5746,26 @@ access the DOM object, create and access Javascript, and generate SMIL
animation content.")
(license (package-license perl))))
+(define-public perl-switch
+ (package
+ (name "perl-switch")
+ (version "2.17")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/C/CH/CHORNY/Switch-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0xbdjdgzfj9zwa4j3ipr8bfk7bcici4hk89hq5d27rhg2isljd9i"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/Switch")
+ (synopsis "Switch statement for Perl")
+ (description "Switch is a Perl module which implements a generalized case
+mechanism. The module augments the standard Perl syntax with two new
+statements: @code{switch} and @code{case}.")
+ (license (package-license perl))))
+
(define-public perl-sys-cpu
(package
(name "perl-sys-cpu")