summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-11-07 20:24:18 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-11-07 20:26:46 +0100
commit152bebd9e0c7fc0863d6b82af014e61a8cb6a488 (patch)
tree16ed100c552b041adb1b426343b1199dd91eab2c /gnu
parentb113f39019913ad8eda4d72624ce9769920d22cb (diff)
downloadguix-patches-152bebd9e0c7fc0863d6b82af014e61a8cb6a488.tar
guix-patches-152bebd9e0c7fc0863d6b82af014e61a8cb6a488.tar.gz
gnu: gemma: Update to 0.98.
* gnu/local.mk (dist_patch_DATA): Remove patch. * gnu/packages/patches/gemma-intel-compat.patch: Remove file. * gnu/packages/bioinformatics.scm (gemma): Update to 0.98. [source]: Remove patch. [inputs]: Add eigen, gfortran:lib, and openblas. [arguments]: Add phase "find-eigen".
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/bioinformatics.scm19
-rw-r--r--gnu/packages/patches/gemma-intel-compat.patch44
3 files changed, 15 insertions, 49 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index bfe93159dc..9a8330aa41 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -722,7 +722,6 @@ dist_patch_DATA = \
%D%/packages/patches/gd-fix-tests-on-i686.patch \
%D%/packages/patches/gd-freetype-test-failure.patch \
%D%/packages/patches/gdm-CVE-2018-14424.patch \
- %D%/packages/patches/gemma-intel-compat.patch \
%D%/packages/patches/geoclue-config.patch \
%D%/packages/patches/ghc-8.0-fall-back-to-madv_dontneed.patch \
%D%/packages/patches/ghc-dont-pass-linker-flags-via-response-files.patch \
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 3cd0e03587..5337b7bf02 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2829,7 +2829,7 @@ comment or quality sections.")
(define-public gemma
(package
(name "gemma")
- (version "0.96")
+ (version "0.98")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2838,11 +2838,13 @@ comment or quality sections.")
(file-name (git-file-name name version))
(sha256
(base32
- "0sa4mllp7890v5pss0mm02ik8yixl7az3vprcw3kp7qmr9gwrdai"))
- (patches (search-patches "gemma-intel-compat.patch"))))
+ "1s3ncnbn45r2hh1cvrqky1kbqq6546biypr4f5mkw1kqlrgyh0yg"))))
(inputs
- `(("gsl" ,gsl)
+ `(("eigen" ,eigen)
+ ("gfortran" ,gfortran "lib")
+ ("gsl" ,gsl)
("lapack" ,lapack)
+ ("openblas" ,openblas)
("zlib" ,zlib)))
(build-system gnu-build-system)
(arguments
@@ -2857,6 +2859,15 @@ comment or quality sections.")
#:phases
(modify-phases %standard-phases
(delete 'configure)
+ (add-after 'unpack 'find-eigen
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Ensure that Eigen headers can be found
+ (setenv "CPLUS_INCLUDE_PATH"
+ (string-append (getenv "CPLUS_INCLUDE_PATH")
+ ":"
+ (assoc-ref inputs "eigen")
+ "/include/eigen3"))
+ #t))
(add-before 'build 'bin-mkdir
(lambda _
(mkdir-p "bin")
diff --git a/gnu/packages/patches/gemma-intel-compat.patch b/gnu/packages/patches/gemma-intel-compat.patch
deleted file mode 100644
index f12ec56d9b..0000000000
--- a/gnu/packages/patches/gemma-intel-compat.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-From da1ed24209121f7b0f03f360b1029d7125a38e70 Mon Sep 17 00:00:00 2001
-From: Efraim Flashner <efraim@flashner.co.il>
-Date: Tue, 4 Jul 2017 12:44:53 +0300
-Subject: [PATCH] Add NO_INTEL_COMPAT flag to Makefile.
-
-see also: https://github.com/xiangzhou/GEMMA/pull/47
-
----
- Makefile | 12 ++++++++----
- 1 file changed, 8 insertions(+), 4 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index 5bb8748..712b1ad 100644
---- a/Makefile
-+++ b/Makefile
-@@ -11,6 +11,7 @@
- SYS = LNX
- # Leave blank after "=" to disable; put "= 1" to enable
- WITH_LAPACK = 1
-+NO_INTEL_COMPAT =
- FORCE_32BIT =
- FORCE_DYNAMIC =
- DIST_NAME = gemma-0.96
-@@ -64,10 +65,13 @@ endif
- HDR += $(SRC_DIR)/lapack.h
- endif
-
--ifdef FORCE_32BIT
-- CPPFLAGS += -m32
--else
-- CPPFLAGS += -m64
-+ifdef NO_INTEL_COMPAT
-+ else
-+ ifdef FORCE_32BIT
-+ CPPFLAGS += -m32
-+ else
-+ CPPFLAGS += -m64
-+ endif
- endif
-
- ifdef FORCE_DYNAMIC
---
-2.13.2
-