summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-04-28 10:17:49 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-04-28 17:01:01 +0200
commited377cc6cfb2cf3eb45c68a7939874fbad6eac59 (patch)
treef1d7ac69767064976825bac4cb8f33c0405867f9 /gnu
parentf67890477afa764b22f4a4d790662f7441e73bcf (diff)
downloadguix-patches-ed377cc6cfb2cf3eb45c68a7939874fbad6eac59.tar
guix-patches-ed377cc6cfb2cf3eb45c68a7939874fbad6eac59.tar.gz
gnu: Add python2-backport-ssl-match-hostname.
* gnu/packages/python.scm (python2-backport-ssl-match-hostname): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 050c0de402..91ed9ce0df 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -301,6 +301,33 @@ etc. ")
(define-public python2-babel
(package-with-python2 python-babel))
+(define-public python2-backport-ssl-match-hostname
+ (package
+ (name "python2-backport-ssl-match-hostname")
+ (version "3.4.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/b/"
+ "backports.ssl_match_hostname/backports.ssl_match_hostname-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1bnn47ipvhy49n0m50v27lp4xj6sqdkdw676ypd7pawsn1zhwh87"))))
+ (build-system python-build-system)
+ (arguments `(#:python ,python-2))
+ (inputs
+ `(("python2-setuptools" ,python2-setuptools)))
+ (home-page "https://pypi.python.org/pypi/backports.ssl_match_hostname")
+ (synopsis "Backport of ssl.match_hostname() function from Python 3.4")
+ (description
+ "This backport brings the ssl.match_hostname() function to users of
+earlier versions of Python. The function checks the hostname in the
+certificate returned by the server to which a connection has been established,
+and verifies that it matches the intended target hostname.")
+ (license psfl)))
+
(define-public python-h5py
(package
(name "python-h5py")