summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2020-10-10 17:47:45 +0000
committerLudovic Courtès <ludo@gnu.org>2020-12-17 14:01:18 +0100
commitddab5244dfa85e5ad73da80c3169fe790387743b (patch)
tree2aaf4f58f4398c60278cbb16dba9b1108f27e36a /gnu
parent4c66a8deb5f51fd4f944fb62c43aa1e2a477711c (diff)
downloadguix-patches-ddab5244dfa85e5ad73da80c3169fe790387743b.tar
guix-patches-ddab5244dfa85e5ad73da80c3169fe790387743b.tar.gz
gnu: Add aws-c-event-stream.
* gnu/packages/c.scm (aws-c-event-stream): New variable. * gnu/packages/patches/aws-c-event-stream-cmake-prefix.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/c.scm27
-rw-r--r--gnu/packages/patches/aws-c-event-stream-cmake-prefix.patch13
3 files changed, 41 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 0daac5746b..aef413abdf 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -823,6 +823,7 @@ dist_patch_DATA = \
%D%/packages/patches/avogadro-python-eigen-lib.patch \
%D%/packages/patches/avidemux-install-to-lib.patch \
%D%/packages/patches/awesome-reproducible-png.patch \
+ %D%/packages/patches/aws-c-event-stream-cmake-prefix.patch \
%D%/packages/patches/aws-checksums-cmake-prefix.patch \
%D%/packages/patches/azr3.patch \
%D%/packages/patches/bash-reproducible-linux-pgrp-pipe.patch \
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index bb3d90e1cd..2ea9c2ac51 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -584,3 +584,30 @@ portability.")
with fallback to efficient C99 software implementations.")
(home-page "https://github.com/awslabs/aws-checksums")
(license license:asl2.0)))
+
+(define-public aws-c-event-stream
+ (package
+ (name "aws-c-event-stream")
+ (version "0.1.6")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://github.com/awslabs/" name))
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1vl9ainc4klv0g9gk1iv4833bsllni6jxn6mwb0fnv2dnlz7zv9q"))
+ (patches (search-patches "aws-c-event-stream-cmake-prefix.patch"))))
+ (build-system cmake-build-system)
+ (propagated-inputs
+ `(("aws-c-common" ,aws-c-common)))
+ (inputs
+ `(("aws-checksums" ,aws-checksums)))
+ (synopsis "Amazon Web Services client-server message format library")
+ (description
+ "This library is a C99 implementation for @acronym{AWS,Amazon Web Services}
+event stream encoding, a binary format for bidirectional client-server
+communication.")
+ (home-page "https://github.com/awslabs/aws-c-event-stream")
+ (license license:asl2.0)))
diff --git a/gnu/packages/patches/aws-c-event-stream-cmake-prefix.patch b/gnu/packages/patches/aws-c-event-stream-cmake-prefix.patch
new file mode 100644
index 0000000000..79655a910b
--- /dev/null
+++ b/gnu/packages/patches/aws-c-event-stream-cmake-prefix.patch
@@ -0,0 +1,13 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -3,6 +3,10 @@
+ cmake_minimum_required (VERSION 3.1)
+ project (aws-c-event-stream C)
+
++if (DEFINED ENV{CMAKE_PREFIX_PATH})
++ set(CMAKE_PREFIX_PATH $ENV{CMAKE_PREFIX_PATH})
++endif()
++
+ if (DEFINED CMAKE_PREFIX_PATH)
+ file(TO_CMAKE_PATH "${CMAKE_PREFIX_PATH}" CMAKE_PREFIX_PATH)
+ endif()