summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-16 23:14:17 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-16 23:14:53 +0100
commit7d3bb433705fd2330719a6971e00ffb5b4b7d29d (patch)
tree9e52cdfbb2ecc06a9532d277c02a3b3ef9ad65e0 /gnu
parente1c58440bda033ec7ebe11b038043a0926b4a25e (diff)
downloadguix-patches-7d3bb433705fd2330719a6971e00ffb5b4b7d29d.tar
guix-patches-7d3bb433705fd2330719a6971e00ffb5b4b7d29d.tar.gz
gnu: Add evolution.
* gnu/packages/gnome.scm (evolution): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm52
1 files changed, 51 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index e3f470fcee..bdd8293b78 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2015 Mathieu Lirzin <mthl@openmailbox.org>
;;; Copyright © 2015, 2017 Andy Wingo <wingo@igalia.com>
;;; Copyright © 2015 David Hashe <david.hashe@dhashe.com>
-;;; Copyright © 2015, 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2016, 2017, 2018 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 David Thompson <davet@gnu.org>
;;; Copyright © 2015, 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
@@ -119,6 +119,7 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages polkit)
#:use-module (gnu packages popt)
+ #:use-module (gnu packages pretty-print)
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages python)
#:use-module (gnu packages python-crypto)
@@ -7557,3 +7558,52 @@ underlying library but cannot for various reasons. In most cases, they are
wildly out of scope for those libraries. In other cases, they are not quite
generic enough to work for everyone.")
(license license:gpl3+)))
+
+(define-public evolution
+ (package
+ (name "evolution")
+ (version "3.28.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/evolution/"
+ (version-major+minor version) "/"
+ "evolution-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0sdv5lg2vlz5f4raymz9d8a5jq4j18vbqyigaip6508p3bjnfj8l"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags
+ (list "-DENABLE_PST_IMPORT=OFF" ; libpst is not packaged
+ "-DENABLE_LIBCRYPTUI=OFF"))) ; libcryptui hasn't seen a release
+ ; in four years and cannot be built.
+ (native-inputs
+ `(("glib" ,glib "bin") ; glib-mkenums
+ ("pkg-config" ,pkg-config)
+ ("intltool" ,intltool)
+ ("itstool" ,itstool)))
+ (inputs
+ `(("enchant" ,enchant)
+ ("evolution-data-server" ,evolution-data-server) ; must be the same version
+ ("gcr" ,gcr)
+ ("gnome-autoar" ,gnome-autoar)
+ ("gnome-desktop" ,gnome-desktop)
+ ("gtkspell3" ,gtkspell3)
+ ("highlight" ,highlight)
+ ("libcanberra" ,libcanberra)
+ ("libgweather" ,libgweather)
+ ("libnotify" ,libnotify)
+ ("libsoup" ,libsoup)
+ ("nss" ,nss)
+ ("openldap" ,openldap)
+ ("webkitgtk" ,webkitgtk)
+ ("ytnef" ,ytnef)))
+ (home-page "https://gitlab.gnome.org/GNOME/evolution")
+ (synopsis "Manage your email, contacts and schedule")
+ (description "Evolution is a personal information management application
+that provides integrated mail, calendaring and address book
+functionality.")
+ ;; See COPYING for details.
+ (license (list license:lgpl2 license:lgpl3 ; either one of these
+ license:openldap2.8 ; addressbook/gui/component/openldap-extract.h
+ license:lgpl2+)))) ; smime/lib/*