summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-05 08:34:23 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:53:41 -0400
commit6d398096e23dc940437c990c86f7043c78a77f8f (patch)
tree0414692b6746ee8cc7f448b917d5ce438eb90195 /gnu
parent99c68135469e53eace92877f7279b4175ef80c8b (diff)
downloadguix-patches-6d398096e23dc940437c990c86f7043c78a77f8f.tar
guix-patches-6d398096e23dc940437c990c86f7043c78a77f8f.tar.gz
gnu: python-urwid-readline: Update to 0.13.
* gnu/packages/python-xyz.scm (python-urwid-readline): Update to 0.13. Re-indent propagated-inputs and native-inputs. [phases]: Delete trailing #t. {check}: Invoke pytest directly, with increased verbosity.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm13
1 files changed, 5 insertions, 8 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5b210bc4d9..80cdf15928 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9150,7 +9150,7 @@ features useful for text console applications.")
(define-public python-urwid-readline
(package
(name "python-urwid-readline")
- (version "0.12")
+ (version "0.13")
(source
(origin
(method git-fetch)
@@ -9160,7 +9160,7 @@ features useful for text console applications.")
(file-name (git-file-name name version))
(sha256
(base32
- "0sq5qgxj7gcfww3ww7idr87isnmp0hi36n241b3q395x1zafdv22"))))
+ "0y9k86p31mlr9rwnrbljvfgl183r5j60yaj0r3scljn1m0mlg8qg"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -9168,12 +9168,9 @@ features useful for text console applications.")
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
- (invoke "python" "-m" "pytest"))
- #t)))))
- (propagated-inputs
- (list python-urwid))
- (native-inputs
- (list python-pytest))
+ (invoke "pytest" "-vv")))))))
+ (propagated-inputs (list python-urwid))
+ (native-inputs (list python-pytest))
(home-page "https://github.com/rr-/urwid_readline")
(synopsis "Text input widget for urwid that supports readline shortcuts")
(description