summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-29 23:48:33 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:53:39 -0400
commit5bd5443ededb922cbbd74e3b271770ca4ddc6bf5 (patch)
tree6c6fe04c28bff4d2b32c64cbd4ff96ab368c6480 /gnu
parent6ce1f74c9a91de93951a480baa2b33d3d2ce6317 (diff)
downloadguix-patches-5bd5443ededb922cbbd74e3b271770ca4ddc6bf5.tar
guix-patches-5bd5443ededb922cbbd74e3b271770ca4ddc6bf5.tar.gz
gnu: Remove python2-docutils.
* gnu/packages/python-xyz.scm (python2-docutils): Delete variable. (python2-docutils-0.14): Likewise.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm15
1 files changed, 0 insertions, 15 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9b04da8acd..6a796b92ad 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4310,9 +4310,6 @@ via commands such as @command{rst2man}, as well as supporting Python code.")
;; licensed under the PFSL, BSD 2-clause, and GPLv3+ licenses.
(license (list license:public-domain license:psfl license:bsd-2 license:gpl3+))))
-(define-public python2-docutils
- (package-with-python2 python-docutils))
-
;; awscli refuses to be built with docutils < 0.16.
(define-public python-docutils-0.15
(package
@@ -4327,18 +4324,6 @@ via commands such as @command{rst2man}, as well as supporting Python code.")
;; tests contain Python 2 syntax.
(arguments '(#:tests? #false))))
-;; python2-sphinx fails its test suite with newer versions.
-(define-public python2-docutils-0.14
- (package
- (inherit python2-docutils)
- (version "0.14")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "docutils" version))
- (sha256
- (base32
- "0x22fs3pdmr42kvz6c654756wja305qv6cx1zbhwlagvxgr4xrji"))))))
-
(define-public python-restructuredtext-lint
(package
(name "python-restructuredtext-lint")