summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-29 23:50:13 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:53:40 -0400
commit139d78581f74721ae9bb4cd473d5d54da8042730 (patch)
tree09abbf5019e862ace48308da5370f52221c3d6dd /gnu
parent74f9e518c674e25ff4598c8887461bb26bbfb8ac (diff)
downloadguix-patches-139d78581f74721ae9bb4cd473d5d54da8042730.tar
guix-patches-139d78581f74721ae9bb4cd473d5d54da8042730.tar.gz
gnu: Remove youtube-dl-gui.
* gnu/packages/video.scm (youtube-dl-gui): Delete variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm97
1 files changed, 0 insertions, 97 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index bddfbf1128..d10382a738 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2528,103 +2528,6 @@ original project.")
(properties '((release-monitoring-url . "https://pypi.org/project/yt-dlp/")))
(home-page "https://github.com/yt-dlp/yt-dlp")))
-(define-public youtube-dl-gui
- (package
- (name "youtube-dl-gui")
- (version "0.4")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "Youtube-DLG" version))
- (sha256
- (base32
- "1bvq2wyn6az59vpdy04dh68fs8m2qzz948xhphibbcpwpcdk00cd"))))
- (build-system python-build-system)
- (arguments
- ;; In Guix, wxpython has not yet been packaged for Python 3.
- `(#:python ,python-2
- ;; This package has no tests.
- #:tests? #f
- #:phases
- (modify-phases %standard-phases
- (add-before 'build 'patch-source
- (lambda* (#:key inputs #:allow-other-keys)
- ;; The youtube-dl-gui program lets you configure options. Some of
- ;; them are problematic, so we change their defaults.
- (substitute* "youtube_dl_gui/optionsmanager.py"
- ;; When this is true, the builder process will try (and fail) to
- ;; write logs to the builder user's home directory.
- (("'enable_log': True") "'enable_log': False")
- ;; This determines which youtube-dl program youtube-dl-gui will
- ;; run. If we don't set this, then youtube-dl-gui might download
- ;; an arbitrary copy from the Internet into the user's home
- ;; directory and run it, so let's make sure youtube-dl-gui uses
- ;; the youtube-dl from the inputs by default.
- (("'youtubedl_path': self.config_path")
- (string-append "'youtubedl_path': '"
- (assoc-ref inputs "youtube-dl")
- "/bin'"))
- ;; When this is True, when youtube-dl-gui is finished downloading
- ;; a file, it will try (and possibly fail) to open the directory
- ;; containing the downloaded file. This can fail because it
- ;; assumes that xdg-open is in PATH. Unfortunately, simply
- ;; adding xdg-utils to the propagated inputs is not enough to
- ;; make this work, so for now we set the default to False.
- (("'open_dl_dir': True") "'open_dl_dir': False"))
- ;; The youtube-dl program from the inputs is actually a wrapper
- ;; script written in bash, so attempting to invoke it as a python
- ;; script will fail.
- (substitute* "youtube_dl_gui/downloaders.py"
- (("cmd = \\['python', self\\.youtubedl_path\\]")
- "cmd = [self.youtubedl_path]"))
- ;; Use relative paths for installing data files so youtube-dl-gui
- ;; installs the files relative to its prefix in the store, rather
- ;; than relative to /. Also, instead of installing data files into
- ;; $prefix/usr/share, install them into $prefix/share for
- ;; consistency (see: (standards) Directory Variables).
- (substitute* "setup.py"
- (("= '/usr/share") "= 'share"))
- ;; Update get_locale_file() so it finds the installed localization
- ;; files.
- (substitute* "youtube_dl_gui/utils.py"
- (("os\\.path\\.join\\('/usr', 'share'")
- (string-append "os.path.join('"
- (assoc-ref %outputs "out")
- "', 'share'")))
- #t))
- (add-after 'install 'create-desktop-file
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (applications (string-append out "/share/applications")))
- (mkdir-p applications)
- (call-with-output-file
- (string-append applications "/youtube-dl-gui.desktop")
- (lambda (file)
- (format
- file
- "[Desktop Entry]~@
- Name=Youtube-dl GUI~@
- Comment=Graphical interface to download video with youtube-dl~@
- Exec=youtube-dl-gui~@
- TryExec=youtube-dl-gui~@
- Terminal=false~@
- Icon=youtube-dl-gui~@
- Type=Application~@
- Categories=AudioVideo;Audio;Video;Network~%")))
- #t))))))
- (native-inputs
- (list gettext-minimal))
- (inputs
- (list python2-twodict python2-wxpython youtube-dl))
- (home-page "https://github.com/MrS0m30n3/youtube-dl-gui")
- (synopsis
- "GUI (Graphical User Interface) for @command{youtube-dl}")
- (description
- "Youtube-dlG is a GUI (Graphical User Interface) for
-@command{youtube-dl}. You can use it to download videos from YouTube and any
-other site that youtube-dl supports.")
- (license license:unlicense)))
-
(define-public you-get
(package
(name "you-get")