summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Thompson <dthompson@vistahigherlearning.com>2016-05-04 12:46:01 -0400
committerDavid Thompson <dthompson@vistahigherlearning.com>2016-05-04 13:22:52 -0400
commitd663e5e6001fa3d23bb80848cd46560c92ea92c8 (patch)
treec1e2eabe63ceebdacbb6fb37b5b53a777af32bb3 /gnu
parent11057c4b58d766f358bc439690b9765bee735772 (diff)
downloadguix-patches-d663e5e6001fa3d23bb80848cd46560c92ea92c8.tar
guix-patches-d663e5e6001fa3d23bb80848cd46560c92ea92c8.tar.gz
gnu: imagemagick: Update to 6.9.3-10.
Fixes CVE-2016–3714. * gnu/packages/imagemagick.scm (imagemagick): Update to 6.9.3-10. [source]: Remove patch. * gnu/packages/patches/imagemagick-test-segv.patch: Delete. * gnu/local.mk (dist_patch_DATA): Remove patch file from distribution.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/imagemagick.scm5
-rw-r--r--gnu/packages/patches/imagemagick-test-segv.patch20
3 files changed, 2 insertions, 24 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index a01efa9224..6f9b1b1019 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -544,7 +544,6 @@ dist_patch_DATA = \
gnu/packages/patches/icu4c-CVE-2015-1270.patch \
gnu/packages/patches/icu4c-CVE-2015-4760.patch \
gnu/packages/patches/ilmbase-fix-tests.patch \
- gnu/packages/patches/imagemagick-test-segv.patch \
gnu/packages/patches/imlib2-CVE-2016-4024.patch \
gnu/packages/patches/irrlicht-mesa-10.patch \
gnu/packages/patches/jasper-CVE-2007-2721.patch \
diff --git a/gnu/packages/imagemagick.scm b/gnu/packages/imagemagick.scm
index 2bdc333d91..095f662376 100644
--- a/gnu/packages/imagemagick.scm
+++ b/gnu/packages/imagemagick.scm
@@ -40,15 +40,14 @@
(define-public imagemagick
(package
(name "imagemagick")
- (version "6.9.2-1")
+ (version "6.9.3-10")
(source (origin
(method url-fetch)
(uri (string-append "mirror://imagemagick/ImageMagick-"
version ".tar.xz"))
(sha256
(base32
- "159afhqrj22jlz745ccbgnkdiwvn8pjcc96jic0iv9ms7gqxwln5"))
- (patches (search-patches "imagemagick-test-segv.patch"))))
+ "0sik2jl1cywnpr5xm28mjhs1l8kxry65f3v2kqzp0cczhwf04gz3"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags '("--with-frozenpaths")
diff --git a/gnu/packages/patches/imagemagick-test-segv.patch b/gnu/packages/patches/imagemagick-test-segv.patch
deleted file mode 100644
index 6626e54828..0000000000
--- a/gnu/packages/patches/imagemagick-test-segv.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-This patch works around a segmentation fault in 'Magick++/tests/color' when
-running 'Magick++/tests/tests.tap'. Here we get an exception early on, which
-is supposedly harmless:
-
- Caught exception: color: UnableToOpenConfigureFile `colors.xml' @ warning/configure.c/GetConfigureOptions/706
-
-However, when the stack unwinders run, 'UnregisterDOTImage' gets called even
-though 'RegisterDOTImage' hadn't been called yet; thus, 'graphic_context' in
-coders/dot.c is NULL, leading to the segfault.
-
---- ImageMagick-6.9.2-1/coders/dot.c 2015-09-16 17:32:42.900323334 +0200
-+++ ImageMagick-6.9.2-1/coders/dot.c 2015-09-16 17:32:48.312367636 +0200
-@@ -240,6 +240,7 @@ ModuleExport void UnregisterDOTImage(voi
- (void) UnregisterMagickInfo("GV");
- (void) UnregisterMagickInfo("DOT");
- #if defined(MAGICKCORE_GVC_DELEGATE)
-+ if (graphic_context != NULL)
- gvFreeContext(graphic_context);
- #endif
- }