summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-07-08 03:55:26 +0000
committerLudovic Courtès <ludo@gnu.org>2021-07-19 19:57:52 +0200
commitc65183b628eed56a9c915b33830b1525701e8526 (patch)
treedee099e4baa31c6d14ec4bafa88acc67f6bf7d0c /gnu
parent6bd1d4a18b9fd21eaaa18ec313481ec9ca863103 (diff)
downloadguix-patches-c65183b628eed56a9c915b33830b1525701e8526.tar
guix-patches-c65183b628eed56a9c915b33830b1525701e8526.tar.gz
gnu: Add python-langdetect.
* gnu/packages/python-xyz.scm (python-langdetect): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 46419d4b45..a70839d80c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10414,6 +10414,26 @@ your package is installed, via @code{pkg_resources} (part of
primary use case is APIs defined before keyword-only parameters existed.")
(license license:gpl3+)))
+(define-public python-langdetect
+ (package
+ (name "python-langdetect")
+ (version "1.0.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "langdetect" version))
+ (sha256
+ (base32 "1805svvb7xjm4sf1j7b6nc3409x37pd1xmabfwwjf1ldkzwgxhfb"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-six" ,python-six)))
+ (home-page "https://github.com/Mimino666/langdetect")
+ (synopsis "Language detection library")
+ (description
+ "This library is a port of Nakatani Shuyo's language-detection library
+(version from 03/03/2014) to Python.")
+ (license license:expat)))
+
(define-public python-pyasn1
(package
(name "python-pyasn1")