summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2020-11-30 10:48:58 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-11-30 22:04:51 +0100
commite61cdf8733ef8211491e499810760454228494d0 (patch)
tree8fa3d72f5e6049f40f2a5b203ace81ea6f3da3e7 /gnu
parent71b15b4874b7f9ec7001d2916a8ab27dcce6cdc0 (diff)
downloadguix-patches-e61cdf8733ef8211491e499810760454228494d0.tar
guix-patches-e61cdf8733ef8211491e499810760454228494d0.tar.gz
gnu: Add python-distlib/next.
* gnu/packages/python-xyz.scm (python-distlib/next): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c71bc49063..cd6681a7f6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5641,6 +5641,19 @@ relate to packaging and distribution of Python software. It is intended to be
used as the basis for third-party packaging tools.")
(license license:psfl)))
+;; TODO: Merge with 'python-distlib' on the next rebuild cycle.
+(define-public python-distlib/next
+ (package
+ (inherit python-distlib)
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "distlib" version ".zip"))
+ (sha256
+ (base32
+ "1wdzv7fsjhrkhh1wfkarlhcwa8m00mgcpdsvknmf2qy8f9l13xpd"))))))
+
(define-public python-distutils-extra
(package
(name "python-distutils-extra")