summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-30 21:04:33 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-30 21:43:36 +0100
commit739174947ef6b3184e3c012cf41a279a13434b4f (patch)
treea3cb3b92a06ede2aaee01447c1b3999c8f69068a /gnu
parent65c110e27a8ce3889d0efecc36b43316265a2d8a (diff)
downloadguix-patches-739174947ef6b3184e3c012cf41a279a13434b4f.tar
guix-patches-739174947ef6b3184e3c012cf41a279a13434b4f.tar.gz
gnu: sudo: Update to 1.9.4.
* gnu/packages/admin.scm (sudo): Update to 1.9.4. [source]: Add patch. * gnu/packages/patches/sudo-fix-build-without-sendmail.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/admin.scm5
-rw-r--r--gnu/packages/patches/sudo-fix-build-without-sendmail.patch45
3 files changed, 49 insertions, 2 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 80f87691fe..c4980c8fde 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1443,6 +1443,7 @@ dist_patch_DATA = \
%D%/packages/patches/sdl-pango-matrix_declarations.patch \
%D%/packages/patches/sdl-pango-sans-serif.patch \
%D%/packages/patches/sqlite-hurd.patch \
+ %D%/packages/patches/sudo-fix-build-without-sendmail.patch \
%D%/packages/patches/sunxi-tools-remove-sys-io.patch \
%D%/packages/patches/patchutils-test-perms.patch \
%D%/packages/patches/patch-hurd-path-max.patch \
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 00bb0add47..96e3ff14d1 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1397,7 +1397,7 @@ system administrator.")
(define-public sudo
(package
(name "sudo")
- (version "1.9.3p1")
+ (version "1.9.4")
(source (origin
(method url-fetch)
(uri
@@ -1407,7 +1407,8 @@ system administrator.")
version ".tar.gz")))
(sha256
(base32
- "17mldsg5d08s23cskmjxfa81ibnqw3slgf3l4023j72ywi9xxffw"))
+ "1w03257akspgkkl757vmpq3p30sb2n6y61hll038mw9sqwnbv4cb"))
+ (patches (search-patches "sudo-fix-build-without-sendmail.patch"))
(modules '((guix build utils)))
(snippet
'(begin
diff --git a/gnu/packages/patches/sudo-fix-build-without-sendmail.patch b/gnu/packages/patches/sudo-fix-build-without-sendmail.patch
new file mode 100644
index 0000000000..f40bfe445e
--- /dev/null
+++ b/gnu/packages/patches/sudo-fix-build-without-sendmail.patch
@@ -0,0 +1,45 @@
+
+# HG changeset patch
+# User Todd C. Miller <Todd.Miller@sudo.ws>
+# Date 1606767492 25200
+# Node ID 41db1aad85bbce444b511bcb28b9628a0a22fcd9
+# Parent 96a5cfe3c66b6ee84d7f7b6fb26d932f45a44b76
+Fix build when configured using --without-sendmail
+Bug #947
+
+diff -r 96a5cfe3c66b -r 41db1aad85bb lib/eventlog/eventlog.c
+--- a/lib/eventlog/eventlog.c Sun Nov 29 15:11:34 2020 -0700
++++ b/lib/eventlog/eventlog.c Mon Nov 30 13:18:12 2020 -0700
+@@ -78,7 +78,7 @@
+ static FILE *eventlog_stub_open_log(int type, const char *logfile);
+ static void eventlog_stub_close_log(int type, FILE *fp);
+
+-/* Eventlog config settings */
++/* Eventlog config settings (default values). */
+ static struct eventlog_config evl_conf = {
+ EVLOG_NONE, /* type */
+ EVLOG_SUDO, /* format */
+@@ -91,7 +91,11 @@
+ false, /* omit_hostname */
+ _PATH_SUDO_LOGFILE, /* logpath */
+ "%h %e %T", /* time_fmt */
++#ifdef _PATH_SUDO_SENDMAIL
+ _PATH_SUDO_SENDMAIL, /* mailerpath */
++#else
++ NULL, /* mailerpath (disabled) */
++#endif
+ "-t", /* mailerflags */
+ NULL, /* mailfrom */
+ MAILTO, /* mailto */
+@@ -1436,8 +1440,10 @@
+ evl_conf.logpath = _PATH_SUDO_LOGFILE;
+ if (evl_conf.time_fmt == NULL)
+ evl_conf.time_fmt = "%h %e %T";
++#ifdef _PATH_SUDO_SENDMAIL
+ if (evl_conf.mailerpath == NULL)
+ evl_conf.mailerpath = _PATH_SUDO_SENDMAIL;
++#endif
+ if (evl_conf.mailerflags == NULL)
+ evl_conf.mailerflags = "-t";
+ if (evl_conf.mailto == NULL)
+