summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-01-16 19:52:17 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-01-19 09:54:15 +0100
commite87cb754a654fe7568cfcd2b60bd43386abede5d (patch)
tree326ce3504ab7b2205854e9f5030a9b85476bb939 /gnu
parent8a9cffb202414b20081910115ba76402924bdcdd (diff)
downloadguix-patches-e87cb754a654fe7568cfcd2b60bd43386abede5d.tar
guix-patches-e87cb754a654fe7568cfcd2b60bd43386abede5d.tar.gz
gnu: Add libgig.
* gnu/packages/music.scm (libgig): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/music.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index c33ce8f83c..b8b97eb141 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -1683,6 +1683,35 @@ synths, microtonal capabilities, custom envelopes, effects, etc. Yoshimi
improves on support for JACK features, such as JACK MIDI.")
(license license:gpl2)))
+(define-public libgig
+ (package
+ (name "libgig")
+ (version "4.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://download.linuxsampler.org/packages/"
+ "libgig-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1wr8mwjmqpnyz6bx9757lspiii1zzn8zfbqsvn2ipzpgqkxv6kaz"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("libuuid" ,util-linux)
+ ("libsndfile" ,libsndfile)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "http://linuxsampler.org/libgig/")
+ (synopsis "C++ library for working with Gigasampler (.gig) files")
+ (description
+ "Libgig is a C++ library for loading, modifying existing and creating new
+Gigasampler (.gig) files and DLS (Downloadable Sounds) Level 1/2 files, KORG
+sample based instruments (.KSF and .KMP files), SoundFont v2 (.sf2) files and
+AKAI sampler data. The package includes a couple of command line tools based
+on the library.")
+ ;; The library and tools are released under the GPL, except the AKAI
+ ;; classes which are released under the LGPL.
+ (license (list license:gpl2+ license:lgpl2.1+))))
+
(define-public jack-keyboard
(package
(name "jack-keyboard")