summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-02-08 16:07:02 +0100
committerLudovic Courtès <ludo@gnu.org>2014-02-08 16:07:02 +0100
commite30835e24797e7e2633d608cfa1f6c8f591a214c (patch)
tree903ae7b2728e6d73de447700c136af89ce955f06 /gnu
parentea0e9ce2e6d0c99106c47ee32203b92933a837de (diff)
downloadguix-patches-e30835e24797e7e2633d608cfa1f6c8f591a214c.tar
guix-patches-e30835e24797e7e2633d608cfa1f6c8f591a214c.tar.gz
gnu: Add FUSE.
* gnu/packages/linux.scm (fuse): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index b88ecfcac0..3fca5dfaf9 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -885,3 +885,38 @@ the command line or a script.")
"Iotop is a Python program with a top like user interface to show the
processes currently causing I/O.")
(license gpl2+)))
+
+(define-public fuse
+ (package
+ (name "fuse")
+ (version "2.9.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/fuse/fuse-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "071r6xjgssy8vwdn6m28qq1bqxsd2bphcd2mzhq0grf5ybm87sqb"))))
+ (build-system gnu-build-system)
+ (native-inputs `(("util-linux" ,util-linux)))
+ (arguments
+ '(#:configure-flags (list (string-append "MOUNT_FUSE_PATH="
+ (assoc-ref %outputs "out")
+ "/sbin")
+ (string-append "INIT_D_PATH="
+ (assoc-ref %outputs "out")
+ "/etc/init.d")
+ (string-append "UDEV_RULES_PATH="
+ (assoc-ref %outputs "out")
+ "/etc/udev"))))
+ (home-page "http://fuse.sourceforge.net/")
+ (synopsis "Support file systems implemented in user space")
+ (description
+ "As a consequence of its monolithic design, file system code for Linux
+normally goes into the kernel itself---which is not only a robustness issue,
+but also an impediment to system extensibility. FUSE, for \"file systems in
+user space\", is a kernel module and user-space library that tries to address
+part of this problem by allowing users to run file system implementations as
+user-space processes.")
+ (license (list lgpl2.1 ; library
+ gpl2+)))) ; command-line utilities