summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJohn Darrington <jmd@gnu.org>2014-12-14 10:07:19 +0100
committerJohn Darrington <jmd@gnu.org>2014-12-14 18:43:22 +0100
commitde51bf58b9d72b83d948d05466075a39c6d0b176 (patch)
tree00d8e99a3deb3a5ffcf61a3a4111591ad31ae677 /gnu
parent61ff0a3a181f093fdcd5d5c7e374db17c5fcd8b9 (diff)
downloadguix-patches-de51bf58b9d72b83d948d05466075a39c6d0b176.tar
guix-patches-de51bf58b9d72b83d948d05466075a39c6d0b176.tar.gz
gnu: Add xdotool.
* gnu/packages/xdisorg.scm (xdotool): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xdisorg.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 6820d018e3..6a84a45376 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -29,6 +29,7 @@
#:use-module (gnu packages image)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages glib)
+ #:use-module (gnu packages perl)
#:use-module (gnu packages xorg))
;; packages outside the x.org system proper
@@ -57,6 +58,47 @@ can also be used for copying files, as an alternative to sftp/scp, thus
avoiding password prompts when X11 forwarding has already been setup.")
(license license:gpl2+)))
+(define-public xdotool
+ (package
+ (name "xdotool")
+ (version "2.20110530.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://semicomplete.googlecode.com/files/" name "-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0rxggg1cy7nnkwidx8x2w3c5f3pk6dh2b6q0q7hp069r3n5jrd77"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; Test suite requires a lot of black magic
+ #:phases
+ (alist-replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys #:rest args)
+ (setenv "PREFIX" (assoc-ref outputs "out"))
+ (setenv "LDFLAGS" (string-append "-Wl,-rpath="
+ (assoc-ref
+ %outputs "out") "/lib"))
+ (setenv "CC" "gcc"))
+ %standard-phases)))
+ (native-inputs `(("perl" ,perl))) ; for pod2man
+ (inputs `(("libx11" ,libx11)
+ ("libxext" ,libxext)
+ ("libxi" ,libxi)
+ ("libxinerama" ,libxinerama)
+ ("libxtst" ,libxtst)))
+ (home-page "http://www.semicomplete.com/projects/xdotool")
+ (synopsis "Fake keyboard/mouse input, window management, and more")
+ (description "Xdotool lets you simulate keyboard input and mouse activity,
+move and resize windows, etc. It does this using X11's XTEST extension and
+other Xlib functions. Additionally, you can search for windows and move,
+resize, hide, and modify window properties like the title. If your window
+manager supports it, you can use xdotool to switch desktops, move windows
+between desktops, and change the number of desktops.")
+ (license license:bsd-3)))
+
(define-public xeyes
(package
(name "xeyes")