summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRaoul Jean Pierre Bonnal <ilpuccio.febo@gmail.com>2017-01-19 19:54:56 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-01-20 15:38:02 +0100
commitc6017f72220ec1dfbdf0b2724f9f8cb7061a31fa (patch)
treec67db4e9de4afb0abba43ad3c1e605d1439c4d20 /gnu
parentb726096bc5fcef1b96554c679b81a34d49265f9c (diff)
downloadguix-patches-c6017f72220ec1dfbdf0b2724f9f8cb7061a31fa.tar
guix-patches-c6017f72220ec1dfbdf0b2724f9f8cb7061a31fa.tar.gz
gnu: Add r-cowplot.
* gnu/packages/statistics.scm (r-cowplot): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/statistics.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 8f72117443..04c01596eb 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -4052,3 +4052,27 @@ published by the statistics blog FiveThirtyEight.")
quadratic forms in normal variables using Imhof's method, Davies's algorithm,
Farebrother's algorithm or Liu et al.'s algorithm.")
(license license:gpl2+)))
+
+(define-public r-cowplot
+ (package
+ (name "r-cowplot")
+ (version "0.7.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "cowplot" version))
+ (sha256
+ (base32
+ "03iimcsh1pk7iqzjdlfcj43b8khijdk4hg00j4jdllv19xsfb0hx"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ggplot2" ,r-ggplot2)
+ ("r-gtable" ,r-gtable)
+ ("r-plyr" ,r-plyr)))
+ (home-page "https://github.com/wilkelab/cowplot")
+ (synopsis "Streamlined plot theme and plot annotations for ggplot2")
+ (description
+ "This package provides some helpful extensions and modifications to the
+ggplot2 package to combine multiple ggplot2 plots into one and label them with
+letters, as is often required for scientific publications.")
+ (license license:gpl2)))