summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2014-12-10 19:38:05 +0800
committer宋文武 <iyzsong@gmail.com>2014-12-12 20:39:12 +0800
commit9a8a040dfe1a8e60949f1204bd5b0dc73d5541b4 (patch)
tree0ba6ada333d8e52278cb232f0efdc391882a93c0 /gnu
parentc5c2f9bbb0d47230ae2e4052ef2ddcc3e9dc704c (diff)
downloadguix-patches-9a8a040dfe1a8e60949f1204bd5b0dc73d5541b4.tar
guix-patches-9a8a040dfe1a8e60949f1204bd5b0dc73d5541b4.tar.gz
gnu: Add xfce4-session.
* gnu/packages/xfce.scm (xfce4-session): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xfce.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 5ea41c7590..c94d2696d4 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -290,3 +290,34 @@ applications menu, workspace switcher and more.")
"Application finder for Xfce, it will show the applications installed on
your system in categories, so you can quickly find and launch them.")
(license gpl2+)))
+
+(define-public xfce4-session
+ (package
+ (name "xfce4-session")
+ (version "4.10.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://archive.xfce.org/xfce/"
+ (version-major+minor version)
+ "/src/" name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1kj65jkjhd0ysf0yxsf88wzpyv6n8i8qgd3gb502hf1x9jksk2mv"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags
+ (list (string-append "--with-xsession-prefix=" %output))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("intltool" ,intltool)))
+ (inputs
+ `(("iceauth" ,iceauth)
+ ("libsm" ,libsm)
+ ("libwnck" ,libwnck-1)
+ ("libxfce4ui" ,libxfce4ui)))
+ (home-page "http://www.xfce.org/")
+ (synopsis "Xfce session manager")
+ (description
+ "Session manager for Xfce, it will restore your session on startup and
+allows you to shutdown the computer from Xfce.")
+ (license gpl2+)))