summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-02-23 13:47:03 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-02-23 13:53:34 +0100
commit937b71dfce3cc203c30cb882095c4c590edd43a3 (patch)
tree64d95e79570a9ed75be6d1bcc9658130310fd301 /gnu
parent93d32da9f8bba815b1effe6358904b5e1f9c73ff (diff)
downloadguix-patches-937b71dfce3cc203c30cb882095c4c590edd43a3.tar
guix-patches-937b71dfce3cc203c30cb882095c4c590edd43a3.tar.gz
gnu: slop: Update to 5.3.21.
* gnu/packages/xdisorg.scm (slop): Update to 5.3.21. [arguments]: Specify -std=gnu++11 in #:configure-flags. [inputs]: Drop LIBX11, LIBXRANDR, IMLIB2 and GLEW. Add GLM.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xdisorg.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index a1c89a5caa..d94455f834 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -51,6 +51,7 @@
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
+ #:use-module (gnu packages maths)
#:use-module (gnu packages m4)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages perl)
@@ -437,7 +438,7 @@ of the screen selected by mouse.")
(define-public slop
(package
(name "slop")
- (version "4.3.21")
+ (version "5.3.21")
(source (origin
(method url-fetch)
(uri (string-append
@@ -446,15 +447,14 @@ of the screen selected by mouse.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0z0p4a3p5mc6fjh5f8js9ppb0maxyvfxpiw2n6nqc5nim1kv6bim"))))
+ "0qlyksiaknd40jabra0fv71k4qc4y6dgxihjmmv9a1g4hdmmqklb"))))
(build-system cmake-build-system)
- (arguments '(#:tests? #f)) ; no "check" target
+ (arguments
+ '(#:configure-flags '("-DCMAKE_CXX_FLAGS=-std=gnu++11")
+ #:tests? #f)) ; no "check" target
(inputs
- `(("libx11" ,libx11)
- ("libxrandr" ,libxrandr)
+ `(("glm" ,glm)
("libxext" ,libxext)
- ("imlib2" ,imlib2)
- ("glew" ,glew)
("mesa" ,mesa)))
(home-page "https://github.com/naelstrof/slop")
(synopsis "Select a region and print its bounds to stdout")