summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMorgan Smith <Morgan.J.Smith@outlook.com>2021-11-11 10:30:03 -0500
committerLudovic Courtès <ludo@gnu.org>2021-11-12 23:56:50 +0100
commit729936cfa4766787218c9e5cf683723544f996f0 (patch)
tree5b9c29f42d75cb054accb952f365d2f615e88480 /gnu
parent18cf347a64fc0b4fe20fd4d172cefe198cbb190c (diff)
downloadguix-patches-729936cfa4766787218c9e5cf683723544f996f0.tar
guix-patches-729936cfa4766787218c9e5cf683723544f996f0.tar.gz
gnu: Add python-sgmllib3k.
* gnu/packages/python-xyz.scm (python-sgmllib3k): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a01a14f29b..e5cdaadb3b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27815,3 +27815,27 @@ simple mock/record and a complete capture/replay framework.")
"Ijson is an iterative JSON parser with standard Python iterator
interfaces.")
(license license:bsd-3)))
+
+(define-public python-sgmllib3k
+ (package
+ (name "python-sgmllib3k")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "sgmllib3k" version))
+ (sha256
+ (base32 "1s8jm3dgqabgf8x96931scji679qkhvczlv3qld4qxpsicfgns3q"))))
+ (build-system python-build-system)
+ ;; Requires a test.html input that is not supplied
+ (arguments
+ `(#:tests? #f))
+ (home-page "https://pypi.org/project/sgmllib3k/")
+ ;; Actual homepage seems to be down
+ ;; (home-page "https://hg.hardcoded.net/sgmllib")
+ (synopsis "Python 3 port of sgmllib")
+ (description
+ "This packages provides an unmaintained port of sgmllib to Python 3.
+It is used to parse text files formatted in @acronym{SGML,Standard Generalized
+Mark-up Language}.")
+ (license license:bsd-3)))