summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-01-14 21:23:36 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-01-15 09:02:48 +0200
commit000f42f4f606f4fdf2e3adb3d9129d693aee0ab5 (patch)
treed42ca6f3c2496d102b28274e11149936c58133aa /gnu
parenta618b6b7cafbb18b653871b901e7f2487fb227ad (diff)
downloadguix-patches-000f42f4f606f4fdf2e3adb3d9129d693aee0ab5.tar
guix-patches-000f42f4f606f4fdf2e3adb3d9129d693aee0ab5.tar.gz
gnu: rust-schannel-0.1: Don't hide package.
* gnu/packages/crates-io.scm (rust-schannel-0.1)[arguments]: Skip build. Add rust-lazy-static-1.3, rust-winapi-0.3 to cargo-inputs. [properties]: Remove field.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 63ffddb7e2..d8ad71db88 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -8585,12 +8585,16 @@ paths point to the same file.")
(base32
"0f9k4pm8yc3z0n1n8hazvnrvg52f0sfxjc91bhf3r76rb3rapxpj"))))
(build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-lazy-static" ,rust-lazy-static-1.3)
+ ("rust-winapi" ,rust-winapi-0.3))))
(home-page "https://github.com/steffengy/schannel-rs")
(synopsis "Rust bindings to the Windows SChannel APIs")
(description
"Rust bindings to the Windows SChannel APIs providing TLS client and
server functionality.")
- (properties '((hidden? . #t)))
(license license:expat)))
(define-public rust-scoped-threadpool-0.1