summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-06-13 11:40:17 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-06-13 11:51:28 +0200
commite83841a296ef7f25a4847aa0e02456bec774a461 (patch)
tree372af85ee3d680a274df81570edbe6850d3404f7 /gnu
parentcbf6017d83e094dda7f0ed96706c15997c9b0660 (diff)
downloadguix-patches-e83841a296ef7f25a4847aa0e02456bec774a461.tar
guix-patches-e83841a296ef7f25a4847aa0e02456bec774a461.tar.gz
gnu: Add r-factominer.
* gnu/packages/cran.scm (r-factominer): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 6bf278bf7d..f3662ef14c 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4316,3 +4316,37 @@ Analysis and its Applications.")
"This package provides a fast implementation of hierarchical
clustering.")
(license license:gpl2+)))
+
+(define-public r-factominer
+ (package
+ (name "r-factominer")
+ (version "1.41")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "FactoMineR" version))
+ (sha256
+ (base32
+ "1h20hydav6l2b7bngqw1av4l5rrh0wk58nhailga1f4qw9lrv259"))))
+ (properties `((upstream-name . "FactoMineR")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-car" ,r-car)
+ ("r-cluster" ,r-cluster)
+ ("r-ellipse" ,r-ellipse)
+ ("r-flashclust" ,r-flashclust)
+ ("r-lattice" ,r-lattice)
+ ("r-leaps" ,r-leaps)
+ ("r-mass" ,r-mass)
+ ("r-scatterplot3d" ,r-scatterplot3d)))
+ (home-page "http://factominer.free.fr")
+ (synopsis "Multivariate exploratory data analysis and data mining")
+ (description
+ "This package provides exploratory data analysis methods to summarize,
+visualize and describe datasets. The main principal component methods are
+available, those with the largest potential in terms of applications:
+principal component analysis (PCA) when variables are quantitative,
+correspondence analysis (CA) and multiple correspondence analysis (MCA) when
+variables are categorical, Multiple Factor Analysis when variables are
+structured in groups, etc. and hierarchical cluster analysis.")
+ (license license:gpl2+)))