summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2014-12-10 19:43:16 +0800
committer宋文武 <iyzsong@gmail.com>2014-12-12 20:44:04 +0800
commit5c776d27060ef2c142bf9d39f40011cf7bdfc558 (patch)
tree59d1891c02ac63c3691b058387151e5544f0c87d /gnu
parent55613927ea9ae7a465dc2a79128e7b65e47ec99e (diff)
downloadguix-patches-5c776d27060ef2c142bf9d39f40011cf7bdfc558.tar
guix-patches-5c776d27060ef2c142bf9d39f40011cf7bdfc558.tar.gz
gnu: Add thunar.
* gnu/packages/xfce.scm (thunar): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xfce.scm36
1 files changed, 35 insertions, 1 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 82296fafec..de369c9fae 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -32,7 +32,10 @@
#:use-module (gnu packages image)
#:use-module (gnu packages gnome)
#:use-module (gnu packages pdf)
- #:use-module (gnu packages gstreamer))
+ #:use-module (gnu packages gstreamer)
+ #:use-module (gnu packages linux)
+ #:use-module (gnu packages photo)
+ #:use-module (gnu packages pcre))
(define-public gtk-xfce-engine
(package
@@ -352,3 +355,34 @@ allows you to shutdown the computer from Xfce.")
"Settings manager for Xfce, it can control various aspects of the desktop
like appearance, display, keyboard and mouse settings.")
(license gpl2+)))
+
+(define-public thunar
+ (package
+ (name "thunar")
+ (version "1.4.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://archive.xfce.org/xfce/4.10/src/"
+ "Thunar-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1fn8wjzkfvnx2giv3rrg2cyrr2c96f9mskgvcji0ixyfcjga249c"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("intltool" ,intltool)))
+ (inputs
+ `(("exo" ,exo)
+ ("gudev", eudev)
+ ("libexif" ,libexif)
+ ("libnotify" ,libnotify)
+ ("libxfce4ui" ,libxfce4ui)
+ ("pcre" ,pcre)
+ ("xfce4-panel" ,xfce4-panel)
+ ("startup-notification" ,startup-notification)))
+ (home-page "http://www.xfce.org/")
+ (synopsis "Xfce file manager")
+ (description
+ "A modern file manager for graphical desktop, aiming to be easy-to-use and
+fast.")
+ (license gpl2+)))