summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-06-13 11:39:20 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-06-13 11:51:28 +0200
commit5219c5c585375c1b92a2320800647eae5e9e09b1 (patch)
tree1acca55eef2a202bf1b9c6e2df0ea240269ab3c7 /gnu
parent85df1a8631014d3e0c7907ddbea53f7a6c490d6b (diff)
downloadguix-patches-5219c5c585375c1b92a2320800647eae5e9e09b1.tar
guix-patches-5219c5c585375c1b92a2320800647eae5e9e09b1.tar.gz
gnu: Add r-ggsignif.
* gnu/packages/cran.scm (r-ggsignif): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index bf4c8a413f..ea4673eb41 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4213,3 +4213,28 @@ Sequence logos can easily be combined with other ggplot2 plots.")
plots in scientific journals, data visualization libraries, science fiction
movies, and TV shows.")
(license license:gpl3)))
+
+(define-public r-ggsignif
+ (package
+ (name "r-ggsignif")
+ (version "0.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ggsignif" version))
+ (sha256
+ (base32
+ "1rn58d7pb3axk6chiihryykrzw76adaa2yiafq4d0j6qbhax78f7"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ggplot2" ,r-ggplot2)))
+ (home-page "https://github.com/const-ae/ggsignif")
+ (synopsis "Significance brackets for ggplot2")
+ (description
+ "Enrich your ggplots with group-wise comparisons. This package provides
+an easy way to indicate if two groups are significantly different. Commonly
+this is shown by a bracket on top connecting the groups of interest which
+itself is annotated with the level of significance. The package provides a
+single layer that takes the groups for comparison and the test as arguments
+and adds the annotation to the plot.")
+ (license license:gpl3)))