summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-01-22 15:42:18 +0100
committerMarius Bakke <marius@gnu.org>2022-02-13 15:15:56 +0100
commitf3803b7c201f42c8508b1b2ea3dd90463e06d75a (patch)
treea8aea61f2d48ad2bc31694079a4647ce3bbf7a26 /gnu
parent4e1c5cf8b1f38cb4b52ebc5bac5e115e3ed693eb (diff)
downloadguix-patches-f3803b7c201f42c8508b1b2ea3dd90463e06d75a.tar
guix-patches-f3803b7c201f42c8508b1b2ea3dd90463e06d75a.tar.gz
gnu: python-idna: Update to 3.3.
* gnu/packages/python-xyz.scm (python-idna): Update to 3.3. [properties]: New field. (python2-idna): Stick with version 2.10.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm16
1 files changed, 13 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 41b60325d2..b002b60e3b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12038,14 +12038,14 @@ versions of Python.")
(define-public python-idna
(package
(name "python-idna")
- (version "2.10")
+ (version "3.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "idna" version))
(sha256
(base32
- "1xmk3s92d2vq42684p61wixfmh3qpr2mw762w0n6662vhlpqf1xk"))))
+ "0v8f6qjfi5i7qc5icsbv2pi24qy6k6m8wjqjvdf2sxjvlpq3yr4x"))))
(build-system python-build-system)
(home-page "https://github.com/kjd/idna")
(synopsis "Internationalized domain names in applications")
@@ -12057,10 +12057,20 @@ from the earlier standard from 2003. The library is also intended to act as a
suitable drop-in replacement for the “encodings.idna” module that comes with
the Python standard library but currently only supports the older 2003
specification.")
+ (properties `((python2-variant . ,(delay python2-idna))))
(license license:bsd-4)))
(define-public python2-idna
- (package-with-python2 python-idna))
+ (let ((base (package-with-python2 (strip-python2-variant python-idna))))
+ (package
+ (inherit base)
+ (version "2.10")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "idna" version))
+ (sha256
+ (base32
+ "1xmk3s92d2vq42684p61wixfmh3qpr2mw762w0n6662vhlpqf1xk")))))))
(define-public python-libsass
(package