summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-02-04 10:21:40 +0100
committerMarius Bakke <marius@gnu.org>2022-02-13 15:15:56 +0100
commitaad0b91c370e2159e2c23d34950cdd5b40ae1636 (patch)
tree33198805f441d08c66631f114ac5251bbc528e10 /gnu
parent6ec96228baf96edc20f93a56566a5e0c7890d081 (diff)
downloadguix-patches-aad0b91c370e2159e2c23d34950cdd5b40ae1636.tar
guix-patches-aad0b91c370e2159e2c23d34950cdd5b40ae1636.tar.gz
gnu: python-chardet: Trim closure size.
* gnu/packages/python-xyz.scm (python-chardet)[arguments]: Override wrap phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 21 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 88f7af2c1b..88edd7de3e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13082,7 +13082,27 @@ simulation, statistical modeling, machine learning and much more.")
(list python-hypothesis python-pytest python-pytest-runner))
(build-system python-build-system)
;; XXX: Incompatible with Pytest 4: <https://github.com/chardet/chardet/issues/173>.
- (arguments `(#:tests? #f))
+ (arguments
+ (list #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; This package provides a 'chardetect' executable that only
+ ;; depends on Python, so customize the wrap phase to avoid
+ ;; adding pytest and friends in order to save size.
+ ;; (See also <https://bugs.gnu.org/25235>.)
+ (replace 'wrap
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((sitedir (site-packages inputs outputs))
+ (python (dirname (dirname
+ (search-input-file
+ inputs "bin/python"))))
+ (python-sitedir
+ (string-append python "/lib/python"
+ (python-version python)
+ "/site-packages")))
+ (wrap-program (string-append #$output "/bin/chardetect")
+ `("GUIX_PYTHONPATH" ":" suffix
+ ,(list sitedir python-sitedir)))))))))
(home-page "https://github.com/chardet/chardet")
(synopsis "Universal encoding detector for Python 2 and 3")
(description