summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-04-12 11:37:57 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-04-12 16:00:01 +0200
commit855097683230b756ba28636bed03ce904b6f3589 (patch)
treed25c2df968b2982ed6dbbb84559c30a2b8d85e1f /gnu
parentdabd0d793c86d07410d182299caec760a41a8f3a (diff)
downloadguix-patches-855097683230b756ba28636bed03ce904b6f3589.tar
guix-patches-855097683230b756ba28636bed03ce904b6f3589.tar.gz
gnu: r-rbowtie: Fix build on architectures other than x86_64.
* gnu/packages/bioconductor.scm (r-rbowtie)[arguments]: Disable use of popcnt on systems other than x86_64.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 04328c6876..803437a033 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -9677,6 +9677,18 @@ Gaussian distributions.")
"0ardmryx6ac7v6n900a1klrrldvbmh7bxvy8ldz8rwid19h29ikr"))))
(properties `((upstream-name . "Rbowtie")))
(build-system r-build-system)
+ (arguments
+ `(#:phases
+ ;; Disable unsupported `popcnt' instructions on
+ ;; architectures other than x86_64
+ ,(if (string-prefix? "x86_64"
+ (or (%current-target-system)
+ (%current-system)))
+ '%standard-phases
+ '(modify-phases %standard-phases
+ (add-after 'unpack 'patch-sources
+ (lambda _
+ (setenv "POPCNT_CAPABILITY" "0")))))))
(inputs (list zlib))
(native-inputs
(list r-knitr))