summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-02-04 11:06:44 +0100
committerMarius Bakke <marius@gnu.org>2022-02-13 15:15:57 +0100
commit7d3a1545f8d0a873807d1c0afed0268b3e3f3acf (patch)
treed072aa43590ead1a403cd40e9eea9a60faf0c29a /gnu
parentcc8d4fa5abd40ed4465dd6173924802d7c81bb26 (diff)
downloadguix-patches-7d3a1545f8d0a873807d1c0afed0268b3e3f3acf.tar
guix-patches-7d3a1545f8d0a873807d1c0afed0268b3e3f3acf.tar.gz
gnu: python-pycparser: Update to 2.21.
* gnu/packages/python-xyz.scm (python-pycparser): Update to 2.21. [arguments]: Adjust check phase. Remove trailing #t's. [native-inputs]: Remove.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm13
1 files changed, 4 insertions, 9 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 09197bdaa1..de2fecd0fc 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7427,26 +7427,22 @@ data, and scientific formats.")
(define-public python-pycparser
(package
(name "python-pycparser")
- (version "2.20")
+ (version "2.21")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pycparser" version))
(sha256
(base32
- "1w0m3xvlrzq4lkbvd1ngfm8mdw64r1yxy6n7djlw6qj5d0km6ird"))))
+ "01kjlyn5w2nn2saj8w1rhq7v26328pd91xwgqn32z1zp2bngsi76"))))
(outputs '("out" "doc"))
(build-system python-build-system)
- (native-inputs
- (list pkg-config))
(arguments
`(#:phases
(modify-phases %standard-phases
(replace 'check
(lambda _
- (with-directory-excursion "tests"
- (invoke "python" "all_tests.py"))
- #t))
+ (invoke "python" "-m" "unittest" "discover")))
(add-after 'install 'install-doc
(lambda* (#:key outputs #:allow-other-keys)
(let* ((data (string-append (assoc-ref outputs "doc") "/share"))
@@ -7457,8 +7453,7 @@ data, and scientific formats.")
(copy-file (string-append "." file)
(string-append doc file)))
'("/README.rst" "/CHANGES" "/LICENSE"))
- (copy-recursively "examples" examples)
- #t))))))
+ (copy-recursively "examples" examples)))))))
(home-page "https://github.com/eliben/pycparser")
(synopsis "C parser in Python")
(description