summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-02-04 10:48:03 +0100
committerMarius Bakke <marius@gnu.org>2022-02-13 15:15:57 +0100
commit447e438aa69dbd9207c90bf68f71e42384a09f73 (patch)
treede50f5f83cfd260a9b8ace8ec963fa86680daade /gnu
parent662d1229677b70428d4630c3b417ee2fce97ed67 (diff)
downloadguix-patches-447e438aa69dbd9207c90bf68f71e42384a09f73.tar
guix-patches-447e438aa69dbd9207c90bf68f71e42384a09f73.tar.gz
gnu: python-chardet: Update to 4.0.0.
* gnu/packages/python-xyz.scm (python-chardet): Update to 4.0.0. [arguments]: Enable tests. Override check phase. [native-inputs]: Remove PYTHON-HYPOTHESIS and PYTHON-PYTEST-RUNNER.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1b23f46f4c..09197bdaa1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13070,22 +13070,23 @@ simulation, statistical modeling, machine learning and much more.")
(define-public python-chardet
(package
(name "python-chardet")
- (version "3.0.4")
+ (version "4.0.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "chardet" version))
(sha256
(base32
- "1bpalpia6r5x1kknbk11p1fzph56fmmnp405ds8icksd3knr5aw4"))))
+ "1ykr04qyhgpc0h5b7dhqw4g92b1xv7ki2ky910mhy4mlbnhm6vqd"))))
(native-inputs
- (list python-hypothesis python-pytest python-pytest-runner))
+ (list python-pytest))
(build-system python-build-system)
- ;; XXX: Incompatible with Pytest 4: <https://github.com/chardet/chardet/issues/173>.
(arguments
- (list #:tests? #f
- #:phases
+ (list #:phases
#~(modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "pytest" "-vv")))
;; This package provides a 'chardetect' executable that only
;; depends on Python, so customize the wrap phase to avoid
;; adding pytest and friends in order to save size.