summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-12-18 00:02:50 +0100
committerMarius Bakke <marius@gnu.org>2020-12-19 22:53:00 +0100
commitae7033ff5ff1d0d2571d808d40add0dd8e97bf8a (patch)
tree38b9e189632159d7baeabafdcf79a72160af13af /gnu
parent3e83e8f431cbda3270f7a0050fc9e1c07827a96b (diff)
downloadguix-patches-ae7033ff5ff1d0d2571d808d40add0dd8e97bf8a.tar
guix-patches-ae7033ff5ff1d0d2571d808d40add0dd8e97bf8a.tar.gz
gnu: python-scipy-documentation: Add a file name for 'scipy-sphinx-theme'.
* gnu/packages/python-xyz.scm (python-numpy-documentation)[native-inputs]: Add a file name for the "scipy-sphinx-time" input.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 11 insertions, 8 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 0f8fd4d270..956bac151a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4756,14 +4756,17 @@ color scales, and color space conversion easy. It has support for:
("texinfo" ,texinfo)
("perl" ,perl)
("scipy-sphinx-theme"
- ,(origin ; The build script expects scipy-sphinx-theme as a git submodule
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/scipy/scipy-sphinx-theme")
- (commit "c466764e2231ba132c09826b5b138fffa1cfcec3")))
- (sha256
- (base32
- "0q2y87clwlsgc7wvlsn9pzyssybcq10plwhq2w1ydykfsyyqbmkl"))))
+ ,(let ((commit "c466764e2231ba132c09826b5b138fffa1cfcec3"))
+ (origin ;the build script expects scipy-sphinx-theme as a git submodule
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/scipy/scipy-sphinx-theme")
+ (commit commit)))
+ (file-name (git-file-name "python-scipy-sphinx-theme"
+ (string-take commit 7)))
+ (sha256
+ (base32
+ "0q2y87clwlsgc7wvlsn9pzyssybcq10plwhq2w1ydykfsyyqbmkl")))))
,@(package-native-inputs python-numpy)))
(arguments
`(#:tests? #f ; we're only generating the documentation