summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorCharles <charles.b.jackson@protonmail.com>2021-09-18 21:38:43 -0500
committerGuillaume Le Vaillant <glv@posteo.net>2021-09-19 09:32:47 +0200
commit173b4e453cf24b21dffafbfd21b9e3007ae215a6 (patch)
tree531c3cfcb3fc5cc8a7b94886593584eca7cf8647 /gnu
parent110fdaad4e9e50e694c1d03a805653482aa7e4bf (diff)
downloadguix-patches-173b4e453cf24b21dffafbfd21b9e3007ae215a6.tar
guix-patches-173b4e453cf24b21dffafbfd21b9e3007ae215a6.tar.gz
gnu: Add cl-funds
* gnu/packages/lisp-xyz.scm (sbcl-funds, ecl-funds, cl-funds): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lisp-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 19948f36b3..451f801db5 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -10753,6 +10753,36 @@ If features:
(define-public ecl-sycamore
(sbcl-package->ecl-package sbcl-sycamore))
+(define-public sbcl-funds
+ (let ((commit "6a93695a83d6e21f7ae1351f9b07ee01fa0b487f")
+ (revision "1"))
+ (package
+ (name "sbcl-funds")
+ (version (git-version "1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/charJe/funds")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0lhzghngihy83njcnhjiqg10lyw8zxfpmg6ly8sycd4vyiw2i249"))))
+ (build-system asdf-build-system/sbcl)
+ (synopsis "Purely functional data structure library in Common Lisp")
+ (description
+ "Funds provides portable, purely functional data structures in Common
+Lisp. It includes tree based implementations for Array, Hash, Queue, Stack, and
+Heap.")
+ (home-page "https://common-lisp.net/project/funds/")
+ (license license:asl2.0))))
+
+(define-public cl-funds
+ (sbcl-package->cl-source-package sbcl-funds))
+
+(define-public ecl-funds
+ (sbcl-package->ecl-package sbcl-funds))
+
(define-public sbcl-trivial-package-local-nicknames
(package
(name "sbcl-trivial-package-local-nicknames")